upgrading from 1.0.0 to 9.5

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

upgrading from 1.0.0 to 9.5

Jeff McKenna
Hello,

I'm a happy FGS-er (version 1.0.0 has been running a long time on
demo.mapserver.org), but now I need to upgrade its MapServer to
MapServer 5.6.x and I am a little confused.  Some points:

   - currently have FGS 1.0.0 with many applications installed
   - MapServer 5.4.0 module enabled
   - no recent MapServer modules are available in FGS 1.0.0
   - latest MapServer 5.6.0 module is available in FGS 9.5

How do I upgrade my existing FGS 1.0.0 to FGS 9.5?  (I apologize if this
is a simple question, but, I'm having a hard time understanding how to
upgrade)

Thanks!

-jeff



--
Jeff McKenna
MapServer Consulting and Training Services
http://www.gatewaygeomatics.com/



_______________________________________________
Foss-gis-suite mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/foss-gis-suite
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: upgrading from 1.0.0 to 9.5

Julien-Samuel Lacroix-2
Hello,

There's not a lot of changes between the 2 versions so it's simply an
upgrade of the packages. Here's one way of doing it:

- Install 9.5 running on another port
- Move all your apps in 9.5
- Test
- Change the port in $FGS_HOME/etc/fgs/pkgs/apache-base/apache.conf to
the one used by your 1.0 installation
- Stop the 1.0
- Restart the 9.5

Julien

Jeff McKenna wrote:

> Hello,
>
> I'm a happy FGS-er (version 1.0.0 has been running a long time on
> demo.mapserver.org), but now I need to upgrade its MapServer to
> MapServer 5.6.x and I am a little confused.  Some points:
>
>    - currently have FGS 1.0.0 with many applications installed
>    - MapServer 5.4.0 module enabled
>    - no recent MapServer modules are available in FGS 1.0.0
>    - latest MapServer 5.6.0 module is available in FGS 9.5
>
> How do I upgrade my existing FGS 1.0.0 to FGS 9.5?  (I apologize if this
> is a simple question, but, I'm having a hard time understanding how to
> upgrade)
>
> Thanks!
>
> -jeff
>
>
>

--
Julien-Samuel Lacroix
Mapgears
http://www.mapgears.com/
_______________________________________________
Foss-gis-suite mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/foss-gis-suite
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: upgrading from 1.0.0 to 9.5

Jeff McKenna
Hi Julien,

Ok thanks, I will manually perform the upgrade (I was just wondering if
there was another way).  Thanks for the fast response :)

-jeff



Julien-Samuel Lacroix wrote:

> Hello,
>
> There's not a lot of changes between the 2 versions so it's simply an
> upgrade of the packages. Here's one way of doing it:
>
> - Install 9.5 running on another port
> - Move all your apps in 9.5
> - Test
> - Change the port in $FGS_HOME/etc/fgs/pkgs/apache-base/apache.conf to
> the one used by your 1.0 installation
> - Stop the 1.0
> - Restart the 9.5
>
> Julien
>
> Jeff McKenna wrote:
>> Hello,
>>
>> I'm a happy FGS-er (version 1.0.0 has been running a long time on
>> demo.mapserver.org), but now I need to upgrade its MapServer to
>> MapServer 5.6.x and I am a little confused.  Some points:
>>
>>    - currently have FGS 1.0.0 with many applications installed
>>    - MapServer 5.4.0 module enabled
>>    - no recent MapServer modules are available in FGS 1.0.0
>>    - latest MapServer 5.6.0 module is available in FGS 9.5
>>
>> How do I upgrade my existing FGS 1.0.0 to FGS 9.5?  (I apologize if this
>> is a simple question, but, I'm having a hard time understanding how to
>> upgrade)
>>



--
Jeff McKenna
MapServer Consulting and Training Services
http://www.gatewaygeomatics.com/


_______________________________________________
Foss-gis-suite mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/foss-gis-suite
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: upgrading from 1.0.0 to 9.5

nsavard
Jeff,

The latest fgs packages can be found here:

http://dl.maptools.org/dl/fgs/dev/dev-20091216/

Norm


Jeff McKenna wrote:

> Hi Julien,
>
> Ok thanks, I will manually perform the upgrade (I was just wondering if
> there was another way).  Thanks for the fast response :)
>
> -jeff
>
>
>
> Julien-Samuel Lacroix wrote:
>  
>> Hello,
>>
>> There's not a lot of changes between the 2 versions so it's simply an
>> upgrade of the packages. Here's one way of doing it:
>>
>> - Install 9.5 running on another port
>> - Move all your apps in 9.5
>> - Test
>> - Change the port in $FGS_HOME/etc/fgs/pkgs/apache-base/apache.conf to
>> the one used by your 1.0 installation
>> - Stop the 1.0
>> - Restart the 9.5
>>
>> Julien
>>
>> Jeff McKenna wrote:
>>    
>>> Hello,
>>>
>>> I'm a happy FGS-er (version 1.0.0 has been running a long time on
>>> demo.mapserver.org), but now I need to upgrade its MapServer to
>>> MapServer 5.6.x and I am a little confused.  Some points:
>>>
>>>    - currently have FGS 1.0.0 with many applications installed
>>>    - MapServer 5.4.0 module enabled
>>>    - no recent MapServer modules are available in FGS 1.0.0
>>>    - latest MapServer 5.6.0 module is available in FGS 9.5
>>>
>>> How do I upgrade my existing FGS 1.0.0 to FGS 9.5?  (I apologize if this
>>> is a simple question, but, I'm having a hard time understanding how to
>>> upgrade)
>>>
>>>      
>
>
>
>  

_______________________________________________
Foss-gis-suite mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/foss-gis-suite
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: upgrading from 1.0.0 to 9.5

Jeff McKenna
Thanks Norm.  I've manually upgraded to the 9.5 release (works excellent
http://demo.mapserver.org/)...but I see you are pointing me to a dev
version...can a module from this dev version
(http://dl.maptools.org/dl/fgs/dev/dev-20091216/) work with the release
version (http://dl.maptools.org/dl/fgs/releases/9.5/) ?

Also, I assume that the 5.6.3 release will be available in the release
version (http://dl.maptools.org/dl/fgs/releases/9.5/) and not the dev
version correct?  (if so then I have no need to move to the dev version).

Sorry for the questions.

-jeff



Normand Savard wrote:
> Jeff,
>
> The latest fgs packages can be found here:
>
> http://dl.maptools.org/dl/fgs/dev/dev-20091216/
>
> Norm



--
Jeff McKenna
MapServer Consulting and Training Services
http://www.gatewaygeomatics.com/


_______________________________________________
Foss-gis-suite mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/foss-gis-suite
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: upgrading from 1.0.0 to 9.5

nsavard
Jeff McKenna wrote:
> but I see you are pointing me to a dev
> version...can a module from this dev version
> (http://dl.maptools.org/dl/fgs/dev/dev-20091216/) work with the release
> version (http://dl.maptools.org/dl/fgs/releases/9.5/) ?
>
>  
No because MapServer was not compiled against the same versions of
libraries.  The dev version will be the next fgs release.  Amongs other
things the dev version contains the php pear package installer.
> Also, I assume that the 5.6.3 release will be available in the release
> version (http://dl.maptools.org/dl/fgs/releases/9.5/) and not the dev
> version correct?  (if so then I have no need to move to the dev version).
>
>  

Yes you're right.  I'll prepare the MapServer 5.6.3 package.


Norm
_______________________________________________
Foss-gis-suite mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/foss-gis-suite
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: upgrading from 1.0.0 to 9.5

Jeff McKenna
Normand Savard wrote:

> Jeff McKenna wrote:
>> but I see you are pointing me to a dev version...can a module from
>> this dev version (http://dl.maptools.org/dl/fgs/dev/dev-20091216/)
>> work with the release version
>> (http://dl.maptools.org/dl/fgs/releases/9.5/) ?
>>
>>  
> No because MapServer was not compiled against the same versions of
> libraries.  The dev version will be the next fgs release.  Amongs other
> things the dev version contains the php pear package installer.

Ok I figured that, thanks for confirmation.

>> Also, I assume that the 5.6.3 release will be available in the release
>> version (http://dl.maptools.org/dl/fgs/releases/9.5/) and not the dev
>> version correct?  (if so then I have no need to move to the dev version).
>>
>>  
>
> Yes you're right.  I'll prepare the MapServer 5.6.3 package.

Great.  (I must do the same for MS4W now also)

-jeff



--
Jeff McKenna
MapServer Consulting and Training Services
http://www.gatewaygeomatics.com/


_______________________________________________
Foss-gis-suite mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/foss-gis-suite
Loading...