Quantcast

messages when installing modules

classic Classic list List threaded Threaded
30 messages Options
12
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

messages when installing modules

Kupen
Hello again,

More questions to ask:
I'm adding pssql module to installation with
fgs install php_pgsql-module:5.2.9 http://dl.maptools.org/dl/fgs/releases/95/modules

I got extra messages and warnings
+ Stoping 'apache':
+ Installing php_pgsql-module:
cat: /opt/fgs/etc/fgs/pkgs/my_files.list/VERSION: Not a directory
  + Getting and extracting module 'php_pgsql-module'... ok
+ Copying all files into FGS environment... ok
* Module 'php_pgsql-module' installed with success.
shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
chdir: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
+ Starting 'apache':

It seems that module is installed, but is it correctly?
At least it's working

--
pk

--
Saunalahti DataPaketti - tilaa nyt, saat 2 kk veloituksetta ja Nettitikun kaupan päälle!
http://saunalahti.fi/gsm/gsmdatapaketti.php 

_______________________________________________
Foss-gis-suite mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/foss-gis-suite
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: messages when installing modules

nsavard
Pena Kupen wrote:

> Hello again,
>
> More questions to ask:
> I'm adding pssql module to installation with
> fgs install php_pgsql-module:5.2.9 http://dl.maptools.org/dl/fgs/releases/95/modules
>
> I got extra messages and warnings
> + Stoping 'apache':
> + Installing php_pgsql-module:
> cat: /opt/fgs/etc/fgs/pkgs/my_files.list/VERSION: Not a directory
>   + Getting and extracting module 'php_pgsql-module'... ok
> + Copying all files into FGS environment... ok
> * Module 'php_pgsql-module' installed with success.
> shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
> chdir: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
> + Starting 'apache':
>
> It seems that module is installed, but is it correctly?
> At least it's working
>
>  
Pena,

I'll check that.  It looks like if a directory has been deleted  hmmm!

Norm
_______________________________________________
Foss-gis-suite mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/foss-gis-suite
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: messages when installing modules

nsavard
Normand Savard wrote:

> Pena Kupen wrote:
>  
>> Hello again,
>>
>> More questions to ask:
>> I'm adding pssql module to installation with
>> fgs install php_pgsql-module:5.2.9 http://dl.maptools.org/dl/fgs/releases/95/modules
>>
>> I got extra messages and warnings
>> + Stoping 'apache':
>> + Installing php_pgsql-module:
>> cat: /opt/fgs/etc/fgs/pkgs/my_files.list/VERSION: Not a directory
>>   + Getting and extracting module 'php_pgsql-module'... ok
>> + Copying all files into FGS environment... ok
>> * Module 'php_pgsql-module' installed with success.
>> shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
>> chdir: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
>> + Starting 'apache':
>>
>> It seems that module is installed, but is it correctly?
>> At least it's working
>>
>>  
>>    
Pena,

I checked the installation of php_pgsql-module as root and it works with
the output pasted below.  I had to modify two files:

/opt/fgs/etc/init.d/apache
/opt/fgs/etc/fgs/pkgs/postgresql-server/install.sh

I changed adduser to useradd because the "-d", "-s" and "-c" switches
were not found.

Norm


root@Manie:/opt/fgs/etc/fgs/pkgs/apache-base# fgs install
php_pgsql-module:5.2.9 http://dl.maptools.org/dl/fgs/releases/9.5/modules
+ Stoping 'apache':
httpd (no pid file) not running
+ Stoping 'pgsql':
pg_ctl: PID file "/opt/fgs/apps/pgsql/data/postmaster.pid" does not exist
Is server running?
+ Installing php_pgsql-module:
cat: /opt/fgs/etc/fgs/pkgs/my_files.list/VERSION: Not a directory
  + Getting and extracting module 'php_pgsql-module'... wget:
/opt/fgs/lib/libcrypto.so.0.9.8: no version information available
(required by wget)
wget: /opt/fgs/lib/libssl.so.0.9.8: no version information available
(required by wget)
ok
+ Copying all files into FGS environment... ok
* Module 'php_pgsql-module' installed with success.
+ Starting 'apache':
+ Starting 'pgsql':
server starting



_______________________________________________
Foss-gis-suite mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/foss-gis-suite
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: messages when installing modules

Kupen
In reply to this post by Kupen
Hi,

I change my /opt/fgs/etc/init.d/apache adduser to useradd
File /opt/fgs/etc/fgs/pkgs/postgresql-server/install.sh does not exists on my installlation. My postgres is running outside of fgs.
My messages shows now:

[root@dev fgs]# fgs install php_pgsql-module:5.2.9 http://dl.maptools.org/dl/fgs/releases/9.5/modules
+ Stoping 'apache':
+ Installing php_pgsql-module:
cat: /opt/fgs/etc/fgs/pkgs/my_files.list/VERSION: Not a directory
  + Getting and extracting module 'php_pgsql-module'... ok
+ Copying all files into FGS environment... ok
* Module 'php_pgsql-module' installed with success.
shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
chdir: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
+ Starting 'apache':

What am I missing?

--
pk

Normand Savard <[hidden email]> kirjoitti:

> Normand Savard wrote:
> > Pena Kupen wrote:
> >  
> >> Hello again,
> >>
> >> More questions to ask:
> >> I'm adding pssql module to installation with
> >> fgs install php_pgsql-module:5.2.9 http://dl.maptools.org/dl/fgs/releases/95/modules
> >>
> >> I got extra messages and warnings
> >> + Stoping 'apache':
> >> + Installing php_pgsql-module:
> >> cat: /opt/fgs/etc/fgs/pkgs/my_files.list/VERSION: Not a directory
> >>   + Getting and extracting module 'php_pgsql-module'... ok
> >> + Copying all files into FGS environment... ok
> >> * Module 'php_pgsql-module' installed with success.
> >> shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
> >> chdir: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
> >> + Starting 'apache':
> >>
> >> It seems that module is installed, but is it correctly?
> >> At least it's working
> >>
> >>  
> >>    
> Pena,
>
> I checked the installation of php_pgsql-module as root and it works with
> the output pasted below.  I had to modify two files:
>
> /opt/fgs/etc/init.d/apache
> /opt/fgs/etc/fgs/pkgs/postgresql-server/install.sh
>
> I changed adduser to useradd because the "-d", "-s" and "-c" switches
> were not found.
>
> Norm
>
>
> root@Manie:/opt/fgs/etc/fgs/pkgs/apache-base# fgs install
> php_pgsql-module:5.2.9 http://dl.maptools.org/dl/fgs/releases/9.5/modules
> + Stoping 'apache':
> httpd (no pid file) not running
> + Stoping 'pgsql':
> pg_ctl: PID file "/opt/fgs/apps/pgsql/data/postmaster.pid" does not exist
> Is server running?
> + Installing php_pgsql-module:
> cat: /opt/fgs/etc/fgs/pkgs/my_files.list/VERSION: Not a directory
>   + Getting and extracting module 'php_pgsql-module'... wget:
> /opt/fgs/lib/libcrypto.so.0.9.8: no version information available
> (required by wget)
> wget: /opt/fgs/lib/libssl.so.0.9.8: no version information available
> (required by wget)
> ok
> + Copying all files into FGS environment... ok
> * Module 'php_pgsql-module' installed with success.
> + Starting 'apache':
> + Starting 'pgsql':
> server starting
>
>
>
>


--
Saunalahti DataPaketti - tilaa nyt, saat 2 kk veloituksetta ja Nettitikun kaupan päälle!
http://saunalahti.fi/gsm/gsmdatapaketti.php 

_______________________________________________
Foss-gis-suite mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/foss-gis-suite
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: messages when installing modules

nsavard
Pena Kupen wrote:

> Hi,
>
> I change my /opt/fgs/etc/init.d/apache adduser to useradd
> File /opt/fgs/etc/fgs/pkgs/postgresql-server/install.sh does not exists on my installlation. My postgres is running outside of fgs.
> My messages shows now:
>
> [root@dev fgs]# fgs install php_pgsql-module:5.2.9 http://dl.maptools.org/dl/fgs/releases/9.5/modules
> + Stoping 'apache':
> + Installing php_pgsql-module:
> cat: /opt/fgs/etc/fgs/pkgs/my_files.list/VERSION: Not a directory
>   + Getting and extracting module 'php_pgsql-module'... ok
> + Copying all files into FGS environment... ok
> * Module 'php_pgsql-module' installed with success.
> shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
> chdir: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
> + Starting 'apache':
>
> What am I missing?
>
>  
Pena,

I'm not sure this could work if posgresql is outside of fgs because all
modules are compiled against a specific version of posgresql.  Try to
install another module not related to posgresql to verify if got the
same error.



Try also to install your fgs environment with the fgs self-installer:

http://dl.maptools.org/dl/fgs/releases/9.5/self-installers/fgs-mapserver_extended_5.4.2-fgs_9.5-linux-i386.bin

meanwhile I'll check in the fgs code to see where this "getcwd" comes from.

Norm
_______________________________________________
Foss-gis-suite mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/foss-gis-suite
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: messages when installing modules

Kupen
In reply to this post by Kupen
I tried with gettext-base and got following

[root@dev fgs]# fgs install gettext-base:0.17 http://dl.maptools.org/dl/fgs/releases/9.5/modules
+ Stoping 'apache':
+ Installing gettext-base:
cat: /opt/fgs/etc/fgs/pkgs/my_files.list/VERSION: Not a directory
  + Getting and extracting module 'gettext-base'... ok
+ Copying all files into FGS environment... ok
* Module 'gettext-base' installed with success.
shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
chdir: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
+ Starting 'apache':

And also with removing:
[root@dev fgs]# fgs remove gettext-base
/opt/fgs/bin/fgs: line 66: local: can only be used in a function
+ Stoping 'apache':
+ Removing gettext-base:
+ Starting 'apache':

I have installed my environment with standard bin, but I also tried with extended.
[root@dev fgs_e]# fgs install php_pgsql-module:5.2.9 http://dl.maptools.org/dl/fgs/releases/9.5/modules
+ Stoping 'apache':
+ Stoping 'pgsql':
pg_ctl: PID file "/opt/fgs_e/apps/pgsql/data/postmaster.pid" does not exist
Is server running?
+ Installing php_pgsql-module:
cat: /opt/fgs_e/etc/fgs/pkgs/my_files.list/VERSION: Not a directory
! Module 'php_pgsql-module' already installed.  To re-install, use force-install option.
+ Starting 'apache':
+ Starting 'pgsql':
server starting
[root@dev fgs_e]# fgs install gettext-base:0.17 http://dl.maptools.org/dl/fgs/releases/9.5/modules
+ Stoping 'apache':
+ Stoping 'pgsql':
pg_ctl: PID file "/opt/fgs_e/apps/pgsql/data/postmaster.pid" does not exist
Is server running?
+ Installing gettext-base:
cat: /opt/fgs_e/etc/fgs/pkgs/my_files.list/VERSION: Not a directory
! Module 'gettext-base' already installed.  To re-install, use force-install option.
+ Starting 'apache':
+ Starting 'pgsql':
server starting

Both of my modules has been installed. And got same messages.

btw - what is corrent way to remove fgs-installation of instance?

--
pk




Normand Savard <[hidden email]> kirjoitti:

> Pena Kupen wrote:
> > Hi,
> >
> > I change my /opt/fgs/etc/init.d/apache adduser to useradd
> > File /opt/fgs/etc/fgs/pkgs/postgresql-server/install.sh does not exists on my installlation. My postgres is running outside of fgs.
> > My messages shows now:
> >
> > [root@dev fgs]# fgs install php_pgsql-module:5.2.9 http://dl.maptools.org/dl/fgs/releases/9.5/modules
> > + Stoping 'apache':
> > + Installing php_pgsql-module:
> > cat: /opt/fgs/etc/fgs/pkgs/my_files.list/VERSION: Not a directory
> >   + Getting and extracting module 'php_pgsql-module'... ok
> > + Copying all files into FGS environment... ok
> > * Module 'php_pgsql-module' installed with success.
> > shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
> > chdir: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
> > + Starting 'apache':
> >
> > What am I missing?
> >
> >  
> Pena,
>
> I'm not sure this could work if posgresql is outside of fgs because all
> modules are compiled against a specific version of posgresql.  Try to
> install another module not related to posgresql to verify if got the
> same error.
>
>
>
> Try also to install your fgs environment with the fgs self-installer:
>
> http://dl.maptools.org/dl/fgs/releases/9.5/self-installers/fgs-mapserver_extended_5.4.2-fgs_9.5-linux-i386.bin
>
> meanwhile I'll check in the fgs code to see where this "getcwd" comes from.
>
> Norm
>


--
Saunalahti DataPaketti - tilaa nyt, saat 2 kk veloituksetta ja Nettitikun kaupan päälle!
http://saunalahti.fi/gsm/gsmdatapaketti.php 

_______________________________________________
Foss-gis-suite mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/foss-gis-suite
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: messages when installing modules

nsavard
Pena Kupen wrote:
>
> btw - what is corrent way to remove fgs-installation of instance?
>
> --
>  
Pena,

Go in your $FGS_HOME, do ". setenv.sh", "fgs stop", "cd ..", "rm -rf fgs".

Norm
_______________________________________________
Foss-gis-suite mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/foss-gis-suite
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: messages when installing modules

nsavard
In reply to this post by nsavard
Normand Savard wrote:

> Pena Kupen wrote:
>  
>> Hi,
>>
>> I change my /opt/fgs/etc/init.d/apache adduser to useradd
>> File /opt/fgs/etc/fgs/pkgs/postgresql-server/install.sh does not exists on my installlation. My postgres is running outside of fgs.
>> My messages shows now:
>>
>> [root@dev fgs]# fgs install php_pgsql-module:5.2.9 http://dl.maptools.org/dl/fgs/releases/9.5/modules
>> + Stoping 'apache':
>> + Installing php_pgsql-module:
>> cat: /opt/fgs/etc/fgs/pkgs/my_files.list/VERSION: Not a directory
>>   + Getting and extracting module 'php_pgsql-module'... ok
>> + Copying all files into FGS environment... ok
>> * Module 'php_pgsql-module' installed with success.
>> shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
>> chdir: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
>> + Starting 'apache':
>>
>> What am I missing?
>>
>>  
>>    
Pena,

Back to the starting point.  Did you get this error when first installing

http://dl.maptools.org/dl/fgs/releases/9.5/modules/fgs-mapserver_extended_5.4.2-fgs_9.5-linux-i386.bin" without installing the php_pgsql-module?

Norm

_______________________________________________
Foss-gis-suite mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/foss-gis-suite
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: messages when installing modules

Kupen
In reply to this post by Kupen
Hi,

You mean when installing with self extracting binary (extended)?
On installation of php_pgsql-module all seems to be ok.

+ Copying all files into FGS environment... ok
* Module 'php_gettext-module' installed with success.
+ Running fgs install php_pgsql-module
* Probing last version of module 'php_pgsql-module'... 5.2.9
+ Installing php_pgsql-module:
  + Getting and extracting module 'php_pgsql-module'... ok
+ Copying all files into FGS environment... ok
* Module 'php_pgsql-module' installed with success.
+ Running fgs install php_mysql-module

--
pk

Normand Savard <[hidden email]> kirjoitti:

> Normand Savard wrote:
> > Pena Kupen wrote:
> >  
> >> Hi,
> >>
> >> I change my /opt/fgs/etc/init.d/apache adduser to useradd
> >> File /opt/fgs/etc/fgs/pkgs/postgresql-server/install.sh does not exists on my installlation. My postgres is running outside of fgs.
> >> My messages shows now:
> >>
> >> [root@dev fgs]# fgs install php_pgsql-module:5.2.9 http://dl.maptools.org/dl/fgs/releases/9.5/modules
> >> + Stoping 'apache':
> >> + Installing php_pgsql-module:
> >> cat: /opt/fgs/etc/fgs/pkgs/my_files.list/VERSION: Not a directory
> >>   + Getting and extracting module 'php_pgsql-module'... ok
> >> + Copying all files into FGS environment... ok
> >> * Module 'php_pgsql-module' installed with success.
> >> shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
> >> chdir: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
> >> + Starting 'apache':
> >>
> >> What am I missing?
> >>
> >>  
> >>    
> Pena,
>
> Back to the starting point.  Did you get this error when first installing
>
> http://dl.maptools.org/dl/fgs/releases/9.5/modules/fgs-mapserver_extended_5.4.2-fgs_9.5-linux-i386.bin" without installing the php_pgsql-module?
>
> Norm
>
>


--
Saunalahti DataPaketti - tilaa nyt, saat 2 kk veloituksetta ja Nettitikun kaupan päälle!
http://saunalahti.fi/gsm/gsmdatapaketti.php 

_______________________________________________
Foss-gis-suite mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/foss-gis-suite
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: messages when installing modules

nsavard
Pena Kupen wrote:

> Hi,
>
> You mean when installing with self extracting binary (extended)?
> On installation of php_pgsql-module all seems to be ok.
>
> + Copying all files into FGS environment... ok
> * Module 'php_gettext-module' installed with success.
> + Running fgs install php_pgsql-module
> * Probing last version of module 'php_pgsql-module'... 5.2.9
> + Installing php_pgsql-module:
>   + Getting and extracting module 'php_pgsql-module'... ok
> + Copying all files into FGS environment... ok
> * Module 'php_pgsql-module' installed with success.
> + Running fgs install php_mysql-module
>
>  
Pena,

So if the php_pgsql-module is installed correctly when you use the
self-installer why are you trying to reinstall it?  I just want to make
sure I understand what you are trying to do exactly.

Norm
_______________________________________________
Foss-gis-suite mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/foss-gis-suite
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: messages when installing modules

Kupen
In reply to this post by Kupen
Norm,

I have installed basic version of fgs. There is no php_pgsql-module included in it so I must add it - shouldn't it?
I do not want to use extended because I'm running postgres on different server.

--
pk

Normand Savard <[hidden email]> kirjoitti:

> Pena Kupen wrote:
> > Hi,
> >
> > You mean when installing with self extracting binary (extended)?
> > On installation of php_pgsql-module all seems to be ok.
> >
> > + Copying all files into FGS environment... ok
> > * Module 'php_gettext-module' installed with success.
> > + Running fgs install php_pgsql-module
> > * Probing last version of module 'php_pgsql-module'... 5.2.9
> > + Installing php_pgsql-module:
> >   + Getting and extracting module 'php_pgsql-module'... ok
> > + Copying all files into FGS environment... ok
> > * Module 'php_pgsql-module' installed with success.
> > + Running fgs install php_mysql-module
> >
> >  
> Pena,
>
> So if the php_pgsql-module is installed correctly when you use the
> self-installer why are you trying to reinstall it?  I just want to make
> sure I understand what you are trying to do exactly.
>
> Norm
>


--
Saunalahti DataPaketti - tilaa nyt, saat 2 kk veloituksetta ja Nettitikun kaupan päälle!
http://saunalahti.fi/gsm/gsmdatapaketti.php 

_______________________________________________
Foss-gis-suite mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/foss-gis-suite
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: messages when installing modules

nsavard
Pena Kupen wrote:
> Norm,
>
> I have installed basic version of fgs. There is no php_pgsql-module included in it so I must add it - shouldn't it?
> I do not want to use extended because I'm running postgres on different server.
>
>  
Pena,

FYI, I retested the installation of FGS basic self-installer as root in
/opt, followed by the installation of php_pgsql-module.  No error comes out.


Norm
_______________________________________________
Foss-gis-suite mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/foss-gis-suite
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: messages when installing modules

Kupen
In reply to this post by Kupen
Hello Norm,

On CentOs 5.3?
Can you post your commands to me, so that I can test with same?
What is yourr root's umask?

--
pk

Normand Savard <[hidden email]> kirjoitti:

> Pena Kupen wrote:
> > Norm,
> >
> > I have installed basic version of fgs. There is no php_pgsql-module included in it so I must add it - shouldn't it?
> > I do not want to use extended because I'm running postgres on different server.
> >
> >  
> Pena,
>
> FYI, I retested the installation of FGS basic self-installer as root in
> /opt, followed by the installation of php_pgsql-module.  No error comes out.
>
>
> Norm
>


--
Saunalahti DataPaketti - tilaa nyt, saat 2 kk veloituksetta ja Nettitikun kaupan päälle!
http://saunalahti.fi/gsm/gsmdatapaketti.php 

_______________________________________________
Foss-gis-suite mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/foss-gis-suite
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: messages when installing modules

nsavard
Pena Kupen wrote:
> Hello Norm,
>
> On CentOs 5.3?
> Can you post your commands to me, so that I can test with same?
> What is yourr root's umask?
>
>  
Pena,

I'm not an administrator could you provide me more information about how
to get the root's umask?

I tested on Ubuntu 8.10 Intrepid.

I followed these steps to install php_pgsql:
sh fgs-mapserver_basic_5.4.2-fgs_9.5-linux-i386.bin
. setenv.sh
fgs install php_pgsql-module


That's it.

Norm
_______________________________________________
Foss-gis-suite mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/foss-gis-suite
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: messages when installing modules

nsavard
In reply to this post by Kupen
Pena Kupen wrote:

> Norm,
>
> I downloaded bin and module as to my /tmp-directory
> wget
> http://maptools.org/dl/fgs/releases/9.5/self-installers/fgs-mapserver_basic_5.4.2-fgs_9.5-linux-i386.bin 
>
> wget
> http://dl.maptools.org/dl/fgs/releases/9.5/modules/fgs-php_pgsql-module-5.2.9-linux-i386.tar.gz 
>
>
> then:
> cd /tmp
> sh fgs-mapserver_basic_5.4.2-fgs_9.5-linux-i386.bin
> /opt/fgs/setenv.sh
> fgs install php_pgsql-module
>
> -->
> -bash-3.2# fgs install php_pgsql-module
> + Stoping 'apache':
> * Module source : '/tmp/fgs-selfextract.s13755'
> * Probing last version of module 'php_pgsql-module'...
> ! Unable to find directory '/tmp/fgs-selfextract.s13755', aborting...
> ! Cannot find a php_pgsql-module module from /tmp/fgs-selfextract.s13755
>
> Fgs installation cannot found module.
>
> then using downloaded file
>
> -bash-3.2# fgs install php_pgsql-module /tmp
> + Stoping 'apache':
> httpd (no pid file) not running
> * Probing last version of module 'php_pgsql-module'... 5.2.9
> + Installing php_pgsql-module:
> cat: /opt/fgs/etc/fgs/pkgs/my_files.list/VERSION: Not a directory
>  + Getting and extracting module 'php_pgsql-module'... ok
> + Copying all files into FGS environment... ok
> * Module 'php_pgsql-module' installed with success.
> shell-init: error retrieving current directory: getcwd: cannot access
> parent directories: No such file or directory
> chdir: error retrieving current directory: getcwd: cannot access
> parent directories: No such file or directory
> + Starting 'apache':
>
> Same errors as before.
>
> So there must be some difference between ubuntu and centos
>
Pena,

You're surely right.  Interesting.  It looks like if a directory has
been deleted.  Don't know what could cause this issue.

Norm
_______________________________________________
Foss-gis-suite mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/foss-gis-suite
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Error from php-mysql module

Alan Hale
Hi - haven't been here for  a while!

I've been running FGS Mapserver with PHP Mapscript happily for a while
now but recently had to move everything to a new server. I took the
opportunity to upgrade to the extended version of FGS 9.5 and also
installed the php-mysql module v. 5.2.9

I'm now getting the warning: "Unable to load dynamic library
'/home/fgs/fgs-dev/built/php/lib/php/extensions/no-debug-non-zts-20060613/php_mysql.so'

and consequently a fatal error 'Call to undefined function mysql_pconnect()'

Needless to say that path does not exist on my server - what is going on?

Many thanks

Alan Hale





__________ Information from ESET Smart Security, version of virus signature database 4367 (20090825) __________

The message was checked by ESET Smart Security.

http://www.eset.com


_______________________________________________
Foss-gis-suite mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/foss-gis-suite
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Error from php-mysql module

Jeff McKenna
Alan Hale wrote:

> Hi - haven't been here for  a while!
>
> I've been running FGS Mapserver with PHP Mapscript happily for a while
> now but recently had to move everything to a new server. I took the
> opportunity to upgrade to the extended version of FGS 9.5 and also
> installed the php-mysql module v. 5.2.9
>
> I'm now getting the warning: "Unable to load dynamic library
> '/home/fgs/fgs-dev/built/php/lib/php/extensions/no-debug-non-zts-20060613/php_mysql.so'
>
> and consequently a fatal error 'Call to undefined function mysql_pconnect()'
>
> Needless to say that path does not exist on my server - what is going on?
>
> Many thanks
>

I would check your php.ini's value for the 'extension_dir", and make
sure that it points to where your 'php_mysql.so' file lives.

-jeff



--
Jeff McKenna
FOSS4G Consulting and Training Services
http://www.gatewaygeomatics.com/




_______________________________________________
Foss-gis-suite mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/foss-gis-suite
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Error from php-mysql module

nsavard
Jeff McKenna wrote:
>
> I would check your php.ini's value for the 'extension_dir", and make
> sure that it points to where your 'php_mysql.so' file lives.
>
> -jeff
>
>
>
>  

Jeff is right.  FGS didn't add a line in php.ini automatically to load
the extension.  Maybe it should.

Norm
_______________________________________________
Foss-gis-suite mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/foss-gis-suite
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Error from php-mysql module

Alan Hale
Normand Savard wrote:
> Jeff McKenna wrote:
>  
>> I would check your php.ini's value for the 'extension_dir", and make
>> sure that it points to where your 'php_mysql.so' file lives.
>>
>>    
Thanks both - I did check this but the default extension_dir path does
not match that indicated by the error message - and in any case the
error still occurs when I correct the path (to "/opt/fgs/www/lib/php5").

Alan


__________ Information from ESET Smart Security, version of virus signature database 4371 (20090826) __________

The message was checked by ESET Smart Security.

http://www.eset.com


_______________________________________________
Foss-gis-suite mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/foss-gis-suite
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Error from php-mysql module

nsavard
Alan Hale wrote:

> Normand Savard wrote:
>  
>> Jeff McKenna wrote:
>>  
>>    
>>> I would check your php.ini's value for the 'extension_dir", and make
>>> sure that it points to where your 'php_mysql.so' file lives.
>>>
>>>    
>>>      
> Thanks both - I did check this but the default extension_dir path does
> not match that indicated by the error message - and in any case the
> error still occurs when I correct the path (to "/opt/fgs/www/lib/php5").
>
>  
Alan,

What does phpinfo says about mysql?  To see the output of phpinfo just
access "<a href="http://localhost:yourport/">http://localhost:yourport/" and click the phpinfo link.

Norm
_______________________________________________
Foss-gis-suite mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/foss-gis-suite
12
Loading...