installation problems

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

installation problems

Worth Lutz
Hi all,

I've messed up my installation trying to upgrade it for mapserver 5.6.0 to
5.6.3.

I forced the mapserver module install and since then things were broken.
Further attempts to correct the problem made things worse.  Here is what I
see now:

--snip----

[root@ClickIT fgs]# fgs start
+ Starting 'apache':
httpd: Syntax error on line 376 of /opt/fgs/www/conf/live.httpd.conf: Syntax
error on line 7 of /opt/fgs/ww                       w/conf.d/php5.conf:
Cannot load /opt/fgs/www/libexec/libphp5.so into server: libjpeg.so.7:
cannot open shar                       ed object file: No such file or
directory
+ Starting 'pgsql':
server starting
[root@ClickIT fgs]#

-- end snip-----



I now cannot even reinstall any of the versions in a different directory.
See the following:

--snip-----

Where do you want to install the FGS suite [/opt/fgs] ? /opt/fgs2

+ Extracting fgs-base.tar.gz from /tmp/fgs-selfextract.Y22787...ok
+ Running base's installer
+ module : base
+ Running fgs install mapserver-php
* Probing last version of module 'mapserver-php'... 5.6.0
+ Installing mapserver-php:
  + Getting and extracting module 'mapserver-php'... ok
    + Getting and extracting module 'mapserver-base'... ok
      + Getting and extracting module 'libstdc++-lib'... ok
      + Getting and extracting module 'libgcc-lib'... ok
      + Getting and extracting module 'apache-base'... ok
        + Getting and extracting module 'expat-base'... ok
      + Getting and extracting module 'gd-lib'... ok
        + Getting and extracting module 'jpeg-lib'... ok
        + Getting and extracting module 'freetype-lib'... ok
        + Getting and extracting module 'libpng-lib'... ok
          + Getting and extracting module 'zlib-lib'... ok
      + Getting and extracting module 'curl-lib'... ok
        + Getting and extracting module 'openssl-lib'... ok
      + Getting and extracting module 'proj-lib'... ok
      + Getting and extracting module 'postgresql-lib'... ok
      + Getting and extracting module 'gdal-base'... ok
        + Getting and extracting module 'tiff-lib'... ok
        + Getting and extracting module 'libgeotiff-lib'... ok
        + Getting and extracting module 'xerces_c-base'... ok
        + Getting and extracting module 'unixODBC-base'...
gzip: stdin: unexpected end of file
tar: Unexpected EOF in archive
tar: Unexpected EOF in archive
tar: Error is not recoverable: exiting now
ok
        + Getting and extracting module 'libungif-base'...
! Cannot find file
'/tmp/fgs-selfextract.Y22787/fgs-libungif-base-4.1.4-linux-i386.tar.gz',
aborting...

! Fatal error, please contact FGS team.
[root@ClickIT temp-wal]#

----end snip------



Any ideas on what to try next?????

Worth Lutz


_______________________________________________
Foss-gis-suite mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/foss-gis-suite
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: installation problems

Worth Lutz

Hi again,

I got the original fgs 5.6.0 version up and running again.

I cannot get the 5.6.3 version to run.

sh fgs-mapserver_extended_5.6.3-fgs_9.5-linux-i386.bin

and I get the following error:

Where do you want to install the FGS suite [/opt/fgs] ? /opt/fgs3

+ Extracting fgs-base.tar.gz from /tmp/fgs-selfextract.X31421...ok
+ Running base's installer
+ module : base
+ Running fgs install mapserver-php
* Probing last version of module 'mapserver-php'... 5.6.3
+ Installing mapserver-php:
  + Getting and extracting module 'mapserver-php'...
! Cannot find file
'/tmp/fgs-selfextract.X31421/fgs-mapserver-php-5.6.3-linux-x86_64.tar.gz',
aborting...

! Fatal error, please contact FGS team.


NOTE THE FOLLOWING LINE:

! Cannot find file
'/tmp/fgs-selfextract.X31421/fgs-mapserver-php-5.6.3-linux-x86_64.tar.gz',
aborting...
 
IT IS ASKING FOR ...5.6.3-linux-x86_64.tar.gz

The files are "i386".  My server is an "x86_64" is this causing the problem?

I'm new at this, thus very confused.


-----Original Message-----
From: [hidden email]
[mailto:[hidden email]] On Behalf Of Worth Lutz
Sent: Friday, June 04, 2010 4:38 PM
To: [hidden email]
Subject: [FGS] installation problems

Hi all,

I've messed up my installation trying to upgrade it for mapserver 5.6.0 to
5.6.3.

I forced the mapserver module install and since then things were broken.
Further attempts to correct the problem made things worse.  Here is what I
see now:

--snip----

[root@ClickIT fgs]# fgs start
+ Starting 'apache':
httpd: Syntax error on line 376 of /opt/fgs/www/conf/live.httpd.conf: Syntax
error on line 7 of /opt/fgs/ww                       w/conf.d/php5.conf:
Cannot load /opt/fgs/www/libexec/libphp5.so into server: libjpeg.so.7:
cannot open shar                       ed object file: No such file or
directory
+ Starting 'pgsql':
server starting
[root@ClickIT fgs]#

-- end snip-----



I now cannot even reinstall any of the versions in a different directory.
See the following:

--snip-----

Where do you want to install the FGS suite [/opt/fgs] ? /opt/fgs2

+ Extracting fgs-base.tar.gz from /tmp/fgs-selfextract.Y22787...ok
+ Running base's installer
+ module : base
+ Running fgs install mapserver-php
* Probing last version of module 'mapserver-php'... 5.6.0
+ Installing mapserver-php:
  + Getting and extracting module 'mapserver-php'... ok
    + Getting and extracting module 'mapserver-base'... ok
      + Getting and extracting module 'libstdc++-lib'... ok
      + Getting and extracting module 'libgcc-lib'... ok
      + Getting and extracting module 'apache-base'... ok
        + Getting and extracting module 'expat-base'... ok
      + Getting and extracting module 'gd-lib'... ok
        + Getting and extracting module 'jpeg-lib'... ok
        + Getting and extracting module 'freetype-lib'... ok
        + Getting and extracting module 'libpng-lib'... ok
          + Getting and extracting module 'zlib-lib'... ok
      + Getting and extracting module 'curl-lib'... ok
        + Getting and extracting module 'openssl-lib'... ok
      + Getting and extracting module 'proj-lib'... ok
      + Getting and extracting module 'postgresql-lib'... ok
      + Getting and extracting module 'gdal-base'... ok
        + Getting and extracting module 'tiff-lib'... ok
        + Getting and extracting module 'libgeotiff-lib'... ok
        + Getting and extracting module 'xerces_c-base'... ok
        + Getting and extracting module 'unixODBC-base'...
gzip: stdin: unexpected end of file
tar: Unexpected EOF in archive
tar: Unexpected EOF in archive
tar: Error is not recoverable: exiting now
ok
        + Getting and extracting module 'libungif-base'...
! Cannot find file
'/tmp/fgs-selfextract.Y22787/fgs-libungif-base-4.1.4-linux-i386.tar.gz',
aborting...

! Fatal error, please contact FGS team.
[root@ClickIT temp-wal]#

----end snip------



Any ideas on what to try next?????

Worth Lutz


_______________________________________________
Foss-gis-suite mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/foss-gis-suite

_______________________________________________
Foss-gis-suite mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/foss-gis-suite
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: installation problems

Daniel Morissette-2
Worth Lutz wrote:

>
> NOTE THE FOLLOWING LINE:
>
> ! Cannot find file
> '/tmp/fgs-selfextract.X31421/fgs-mapserver-php-5.6.3-linux-x86_64.tar.gz',
> aborting...
>  
> IT IS ASKING FOR ...5.6.3-linux-x86_64.tar.gz
>
> The files are "i386".  My server is an "x86_64" is this causing the problem?
>

Yup, that looks like a bug in the installer script.

I don't have time to look into this, but hopefully Alan or another dev
will see this and get back to you in the next few days.

Daniel
--
Daniel Morissette
http://www.mapgears.com/
_______________________________________________
Foss-gis-suite mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/foss-gis-suite
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: installation problems

nsavard
Daniel Morissette wrote:

> Worth Lutz wrote:
>  
>> NOTE THE FOLLOWING LINE:
>>
>> ! Cannot find file
>> '/tmp/fgs-selfextract.X31421/fgs-mapserver-php-5.6.3-linux-x86_64.tar.gz',
>> aborting...
>>  
>> IT IS ASKING FOR ...5.6.3-linux-x86_64.tar.gz
>>
>> The files are "i386".  My server is an "x86_64" is this causing the problem?
>>
>>    
>
>  
The installer script detects the platform you are working on and try to
extract the corresponding package.  I can see three choices:

1- if you installed the ia32-libs, modify the script to always ask for
"i386" package
2- build FGS on your machine
3- ask Mapgears to do a FGS 64

Norm
_______________________________________________
Foss-gis-suite mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/foss-gis-suite
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: installation problems

Worth Lutz
That makes sense, but I'm running the i386 version, I think, with the 5.6.0
version.  That version loaded with no errors.  Is there a difference in the
installation details?  I do not know about the ia32-libs, but will try to
check.

Worth

-----Original Message-----
From: [hidden email]
[mailto:[hidden email]] On Behalf Of Normand
Savard
Sent: Sunday, June 06, 2010 11:40 AM
To: Daniel Morissette
Cc: [hidden email]
Subject: Re: [FGS] installation problems

Daniel Morissette wrote:
> Worth Lutz wrote:
>  
>> NOTE THE FOLLOWING LINE:
>>
>> ! Cannot find file
>>
'/tmp/fgs-selfextract.X31421/fgs-mapserver-php-5.6.3-linux-x86_64.tar.gz',
>> aborting...
>>  
>> IT IS ASKING FOR ...5.6.3-linux-x86_64.tar.gz
>>
>> The files are "i386".  My server is an "x86_64" is this causing the
problem?
>>
>>    
>
>  
The installer script detects the platform you are working on and try to
extract the corresponding package.  I can see three choices:

1- if you installed the ia32-libs, modify the script to always ask for
"i386" package
2- build FGS on your machine
3- ask Mapgears to do a FGS 64

Norm
_______________________________________________
Foss-gis-suite mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/foss-gis-suite

_______________________________________________
Foss-gis-suite mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/foss-gis-suite
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: installation problems

nsavard
Worth,

There is no difference in the installation steps.  I think I found the
problem.  I'll come back to you.

Norm

Worth Lutz wrote:

> That makes sense, but I'm running the i386 version, I think, with the 5.6.0
> version.  That version loaded with no errors.  Is there a difference in the
> installation details?  I do not know about the ia32-libs, but will try to
> check.
>
> Worth
>
> -----Original Message-----
> From: [hidden email]
> [mailto:[hidden email]] On Behalf Of Normand
> Savard
> Sent: Sunday, June 06, 2010 11:40 AM
> To: Daniel Morissette
> Cc: [hidden email]
> Subject: Re: [FGS] installation problems
>
> Daniel Morissette wrote:
>  
>> Worth Lutz wrote:
>>  
>>    
>>> NOTE THE FOLLOWING LINE:
>>>
>>> ! Cannot find file
>>>
>>>      
> '/tmp/fgs-selfextract.X31421/fgs-mapserver-php-5.6.3-linux-x86_64.tar.gz',
>  
>>> aborting...
>>>  
>>> IT IS ASKING FOR ...5.6.3-linux-x86_64.tar.gz
>>>
>>> The files are "i386".  My server is an "x86_64" is this causing the
>>>      
> problem?
>  
>>>    
>>>      
>>  
>>    
> The installer script detects the platform you are working on and try to
> extract the corresponding package.  I can see three choices:
>
> 1- if you installed the ia32-libs, modify the script to always ask for
> "i386" package
> 2- build FGS on your machine
> 3- ask Mapgears to do a FGS 64
>
> Norm
> _______________________________________________
> Foss-gis-suite mailing list
> [hidden email]
> http://lists.maptools.org/mailman/listinfo/foss-gis-suite
>
>
>  

_______________________________________________
Foss-gis-suite mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/foss-gis-suite
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: installation problems

nsavard
In reply to this post by Worth Lutz
Worth,

Please try the new self-installer found here:

http://dl.maptools.org/dl/fgs/releases/9.5/self-installers/

Regards,

Norm

Worth Lutz wrote:

> That makes sense, but I'm running the i386 version, I think, with the 5.6.0
> version.  That version loaded with no errors.  Is there a difference in the
> installation details?  I do not know about the ia32-libs, but will try to
> check.
>
> Worth
>
> -----Original Message-----
> From: [hidden email]
> [mailto:[hidden email]] On Behalf Of Normand
> Savard
> Sent: Sunday, June 06, 2010 11:40 AM
> To: Daniel Morissette
> Cc: [hidden email]
> Subject: Re: [FGS] installation problems
>
> Daniel Morissette wrote:
>  
>> Worth Lutz wrote:
>>  
>>    
>>> NOTE THE FOLLOWING LINE:
>>>
>>> ! Cannot find file
>>>
>>>      
> '/tmp/fgs-selfextract.X31421/fgs-mapserver-php-5.6.3-linux-x86_64.tar.gz',
>  
>>> aborting...
>>>  
>>> IT IS ASKING FOR ...5.6.3-linux-x86_64.tar.gz
>>>
>>> The files are "i386".  My server is an "x86_64" is this causing the
>>>      
> problem?
>  
>>>    
>>>      
>>  
>>    
> The installer script detects the platform you are working on and try to
> extract the corresponding package.  I can see three choices:
>
> 1- if you installed the ia32-libs, modify the script to always ask for
> "i386" package
> 2- build FGS on your machine
> 3- ask Mapgears to do a FGS 64
>
> Norm
> _______________________________________________
> Foss-gis-suite mailing list
> [hidden email]
> http://lists.maptools.org/mailman/listinfo/foss-gis-suite
>
>
>  

_______________________________________________
Foss-gis-suite mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/foss-gis-suite
Loading...