https for php

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

https for php

pkorduan

Hi,

 

how can I activate the SSL Transport Protokoll for PHP after a successfull installation of fgs including the package: fgs-apache_mod_ssl-module-2.2.8-linux-i386.tar.gz.

 

The apache is running with both protokolls http and https but if I call phpinfo() only the

 

 Registered Stream Socket Transports: tcp, udp, unix, udg

 

are listed. So I can not use calls like file_get_contents("https://www.server.xy/"); with PHP

 

The result is empty or if I try to call http://www.server.xy/ the result is: “Unable to find the socket transport "ssl" - did you forget to enable it when you configured PHP?”

Because the server http://www.server.xy always route to https://www.server.xy.

 

I can not activate the https protokoll support by enabling the extension=php_openssl.dll in php.ini because it’s for the windows distributions you know and a php_openssl.so don’t exist actually in the directory www/lib/php5/.

 

Is it enough to install fgs-openssl-lib-0.9.8k-linux-i386.tar.gz but I hasitate, because it’s not a php module.

Is it a problem with curl or with php?

Currently I have the following packages installed.

 

 * FGS API version : 9.5

* NAME                      VERSION

cat: /home/fgs/fgs/etc/fgs/pkgs/my_files.list/VERSION: Ist kein Verzeichnis

* agg-lib                   2.4

* apache-base               2.2.11

* apache_mod_ssl-module     2.2.8

* curl-lib                  7.19.4

* expat-base                2.0.1

* freetype-lib              2.3.9

* gdal-base                 1.6.1

* gd-lib                    2.0.35

* geos-lib                  3.1.0

* gmap-demo                 1.0.0

* imagemagick-base          6.5.1-10

* jpeg-lib                  6b

* libgcc-lib                1

* libgeotiff-lib            1.2.5

* libiconv-base             1.12

* libpng-lib                1.2.35

* libstdc++-lib             6.0.8

* libungif-base             4.1.4

* libxml2-base              2.7.3

* mapserver-base            5.4.2

* mapserver-php             5.4.0

* ming-lib                  0.4.2

* my_files.list

* openssl-lib               0.9.8k

* php-base                  5.2.5

* php_curl-module           5.2.5

* php_http-module           1.6.0

* php_mysql-module          5.2.9

* php_pgsql-module          5.2.9

* postgis-lib               1.3.5

* postgresql-lib            8.3.7

* postgresql-server         8.3.7

* proj4_epsg42xxx-support   proj

* proj-lib                  4.6.1

* tiff-lib                  3.8.2

* unixODBC-base             2.2.12

* xerces_c-base             3.0.1

* zlib-lib                  1.2.3

 

 

Thanks for any respons,

 

Kind Regards Peter Korduan

 

Universität Rostock

Agrar- und Umweltwissenschaftliche Fakultät

Institut für Management ländlicher Räume

Justus-von-Liebig-Weg 6

18059 Rostock

 


_______________________________________________
Foss-gis-suite mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/foss-gis-suite
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: https for php

Julien-Samuel Lacroix-2
Hi,

Sorry there's no openssl package for php in FGS (needed to open https
url). You can make one or use cURL to open https URL.

Best regards,
Julien

On 10-07-20 12:24 PM, Peter Korduan wrote:

> Hi,
>
> how can I activate the SSL Transport Protokoll for PHP after a
> successfull installation of fgs including the package:
> *fgs-apache_mod_ssl-module-2.2.8-linux-i386.tar.gz*.
>
> The apache is running with both protokolls http and https but if I call
> phpinfo() only the
>
> Registered Stream Socket Transports: tcp, udp, unix, udg
>
> are listed. So I can not use calls like
> file_get_contents("https://www.server.xy/"); with PHP
>
> The result is empty or if I try to call http://www.server.xy/ the result
> is: “Unable to find the socket transport "ssl" - did you forget to
> enable it when you configured PHP?”
>
> Because the server http://www.server.xy always route to
> https://www.server.xy.
>
> I can not activate the https protokoll support by enabling the
> extension=php_openssl.dll in php.ini because it’s for the windows
> distributions you know and a php_openssl.so don’t exist actually in the
> directory www/lib/php5/.
>
> Is it enough to install *fgs-openssl-lib-0.9.8k-linux-i386.tar.gz* but I
> hasitate, because it’s not a php module.
>
> Is it a problem with curl or with php?
>
> Currently I have the following packages installed.
>
>   * FGS API version : 9.5
>
> * NAME                      VERSION
>
> cat: /home/fgs/fgs/etc/fgs/pkgs/my_files.list/VERSION: Ist kein Verzeichnis
>
> * agg-lib                   2.4
>
> * apache-base               2.2.11
>
> * apache_mod_ssl-module     2.2.8
>
> * curl-lib                  7.19.4
>
> * expat-base                2.0.1
>
> * freetype-lib              2.3.9
>
> * gdal-base                 1.6.1
>
> * gd-lib                    2.0.35
>
> * geos-lib                  3.1.0
>
> * gmap-demo                 1.0.0
>
> * imagemagick-base          6.5.1-10
>
> * jpeg-lib                  6b
>
> * libgcc-lib                1
>
> * libgeotiff-lib            1.2.5
>
> * libiconv-base             1.12
>
> * libpng-lib                1.2.35
>
> * libstdc++-lib             6.0.8
>
> * libungif-base             4.1.4
>
> * libxml2-base              2.7.3
>
> * mapserver-base            5.4.2
>
> * mapserver-php             5.4.0
>
> * ming-lib                  0.4.2
>
> * my_files.list
>
> * openssl-lib               0.9.8k
>
> * php-base                  5.2.5
>
> * php_curl-module           5.2.5
>
> * php_http-module           1.6.0
>
> * php_mysql-module          5.2.9
>
> * php_pgsql-module          5.2.9
>
> * postgis-lib               1.3.5
>
> * postgresql-lib            8.3.7
>
> * postgresql-server         8.3.7
>
> * proj4_epsg42xxx-support   proj
>
> * proj-lib                  4.6.1
>
> * tiff-lib                  3.8.2
>
> * unixODBC-base             2.2.12
>
> * xerces_c-base             3.0.1
>
> * zlib-lib                  1.2.3
>
> Thanks for any respons,
>
> Kind Regards Peter Korduan
>
> Universität Rostock
>
> Agrar- und Umweltwissenschaftliche Fakultät
>
> Institut für Management ländlicher Räume
>
> Justus-von-Liebig-Weg 6
>
> 18059 Rostock
>
>
>
> _______________________________________________
> Foss-gis-suite mailing list
> [hidden email]
> http://lists.maptools.org/mailman/listinfo/foss-gis-suite

--
Julien-Samuel Lacroix
Mapgears
http://www.mapgears.com/
_______________________________________________
Foss-gis-suite mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/foss-gis-suite
Loading...