Quantcast

cartoweb 3.5 query_by_bbox

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

cartoweb 3.5 query_by_bbox

Stefan Neumeier
Dear all,

I encounter following error using the query_by_bbox -tool:

When I use the tool the first time I am able to define a bounding box
and execute the query as expected. Using the same tool a second time
(e.g. for executing another query) I am able to draw the bounding box
but only the query result of the start point is returned, not the one of
the bounding box. As far as I could figure out this strange behaviour
does only occur when I use Firefox as webbrowser. If I use Opera
everything works as expected.

Has anyone of you already encountered the same behaviour and found
a workaround?


Stefan
_______________________________________________
Cartoweb-users mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/cartoweb-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: cartoweb 3.5 query_by_bbox

Oliver Christen
hi Stefan

I havent heard of that problem before.
I tested on the demo http://www.cartoweb.org/demos/demoCW3.php using FF3.4
and 4.1 without being able to reproduce the problem.

in Firebug, try to look at the ajax request done and see if the geometry
sent for the second query is a point or a rectangle (and that is is indeed
the right rectangle, as if I recall correctly even a simple point clic
return a very tiny rectangle)

regards
Oliver

> Dear all,
>
> I encounter following error using the query_by_bbox -tool:
>
> When I use the tool the first time I am able to define a bounding box
> and execute the query as expected. Using the same tool a second time
> (e.g. for executing another query) I am able to draw the bounding box
> but only the query result of the start point is returned, not the one of
> the bounding box. As far as I could figure out this strange behaviour
> does only occur when I use Firefox as webbrowser. If I use Opera
> everything works as expected.
>
> Has anyone of you already encountered the same behaviour and found
> a workaround?
>
>
> Stefan
> _______________________________________________
> Cartoweb-users mailing list
> [hidden email]
> http://lists.maptools.org/mailman/listinfo/cartoweb-users
>

_______________________________________________
Cartoweb-users mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/cartoweb-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: cartoweb 3.5 query_by_bbox

Simone Frigerio-2
In reply to this post by Stefan Neumeier
Dear Stefan,
I looked now your message and I encountered on a similar "strange"
problem. My task was regarding the link (external URL) to layers or
group of layers. The syntax was correctly tested, and working on my
machine. The project was transfered on another pc and an error on link
tool appeared, without reason.... We checked everything, without
results. The final solution was simply the upgrade of Firefox version.
This strange behaviours occurs with Firefox, If I use Opera everything
works as expected.

Regards
Simone



Il 17/05/2011 19:00, [hidden email] ha scritto:

> Send Cartoweb-users mailing list submissions to
> [hidden email]
>
> To subscribe or unsubscribe via the World Wide Web, visit
> http://lists.maptools.org/mailman/listinfo/cartoweb-users
> or, via email, send a message with subject or body 'help' to
> [hidden email]
>
> You can reach the person managing the list at
> [hidden email]
>
> When replying, please edit your Subject line so it is more specific
> than "Re: Contents of Cartoweb-users digest..."
>
>
> Today's Topics:
>
>     1. Re: cartoweb 3.5 query_by_bbox (Oliver Christen)
>
>
> ----------------------------------------------------------------------
>
> Message: 1
> Date: Tue, 17 May 2011 10:55:27 +0200
> From: "Oliver Christen"<[hidden email]>
> Subject: Re: [Cartoweb-users] cartoweb 3.5 query_by_bbox
> To:<[hidden email]>, <[hidden email]>
> Message-ID:<F135CFC3A7F54A22A4EB838D8C8299EC@maunakea>
> Content-Type: text/plain; format=flowed; charset="iso-8859-1";
> reply-type=original
>
> hi Stefan
>
> I havent heard of that problem before.
> I tested on the demo http://www.cartoweb.org/demos/demoCW3.php using FF3.4
> and 4.1 without being able to reproduce the problem.
>
> in Firebug, try to look at the ajax request done and see if the geometry
> sent for the second query is a point or a rectangle (and that is is indeed
> the right rectangle, as if I recall correctly even a simple point clic
> return a very tiny rectangle)
>
> regards
> Oliver
>
>> Dear all,
>>
>> I encounter following error using the query_by_bbox -tool:
>>
>> When I use the tool the first time I am able to define a bounding box
>> and execute the query as expected. Using the same tool a second time
>> (e.g. for executing another query) I am able to draw the bounding box
>> but only the query result of the start point is returned, not the one of
>> the bounding box. As far as I could figure out this strange behaviour
>> does only occur when I use Firefox as webbrowser. If I use Opera
>> everything works as expected.
>>
>> Has anyone of you already encountered the same behaviour and found
>> a workaround?
>>
>>
>> Stefan
>> _______________________________________________
>> Cartoweb-users mailing list
>> [hidden email]
>> http://lists.maptools.org/mailman/listinfo/cartoweb-users
>>
>
>
> ------------------------------
>
> _______________________________________________
> Cartoweb-users mailing list
> [hidden email]
> http://lists.maptools.org/mailman/listinfo/cartoweb-users
>
>
> End of Cartoweb-users Digest, Vol 72, Issue 2
> *********************************************
>
>


--
** Think about the environment before printing **

Simone Frigerio
Department of Geography and Regional Research
University of Vienna
Universitaestrasse 7, A-1010 Vienna, Austria

mail: [hidden email]

_______________________________________________
Cartoweb-users mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/cartoweb-users
Loading...