MapLab preview error

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

MapLab preview error

Walter Luperini
 
 
hi
I installed ms4w and after maplab on windows xp. 
By internet explorer went on http://localhost/, maplab is between applications.
I can open the page http://localhost/maplab/
Once launched mapedit, I load the map test "tutorial.map" which is in ms4w/apps/maplab-2.2.1/tutorial /.
The map is loaded.
When i click on preview map, the map opens but the layers are not visible, if use one of the tools (zoom in, zoom out),
these errors appear
 
Warning: [MapServer Error]: msDrawMap(): Failed to draw layer named 'grid'. in C:\ms4w\apps\maplab-2.2.1\htdocs\mapedit\preview.php on line 472

Warning: [MapServer Error]: msDBFGetItemIndex(): Item 'Capital' not found. in C:\ms4w\apps\maplab-2.2.1\htdocs\mapedit\preview.php on line 472

Fatal error: Call to a member function saveWebImage() on a non-object in C:\ms4w\apps\maplab-2.2.1\htdocs\mapedit\preview.php on line 477
Someone knows why?
thanks Walter

_______________________________________________
Maplab-users mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/maplab-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: MapLab preview error

Rahkonen Jukka
MapLab does not work with new ms4w packeges.  I found from my machine an old ms4w version that works, and it seems to be two and a half years old.  I would recommend you to forget the whole idea and start looking for other alternatives.  MapLab was simple and nice package for getting an idea about interactive MapServer application, but it is gone.
 
-Jukka Rahkonen-
 
 

Lähettäjä: [hidden email] [mailto:[hidden email]] Puolesta Walter Luperini
Lähetetty: 26. syyskuuta 2008 11:40
Vastaanottaja: [hidden email]
Aihe: [maplab-users] MapLab preview error

 
 
hi
I installed ms4w and after maplab on windows xp. 
By internet explorer went on http://localhost/, maplab is between applications.
I can open the page http://localhost/maplab/
Once launched mapedit, I load the map test "tutorial.map" which is in ms4w/apps/maplab-2.2.1/tutorial /.
The map is loaded.
When i click on preview map, the map opens but the layers are not visible, if use one of the tools (zoom in, zoom out),
these errors appear
 
Warning: [MapServer Error]: msDrawMap(): Failed to draw layer named 'grid'. in C:\ms4w\apps\maplab-2.2.1\htdocs\mapedit\preview.php on line 472

Warning: [MapServer Error]: msDBFGetItemIndex(): Item 'Capital' not found. in C:\ms4w\apps\maplab-2.2.1\htdocs\mapedit\preview.php on line 472

Fatal error: Call to a member function saveWebImage() on a non-object in C:\ms4w\apps\maplab-2.2.1\htdocs\mapedit\preview.php on line 477
Someone knows why?
thanks Walter

_______________________________________________
Maplab-users mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/maplab-users
Loading...