Quantcast

GLIBC version dependency

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

GLIBC version dependency

Jeff McKenna
Hello FGS-ers,

I am trying to implement FGS 9.5, on a machine that I have no root
privileges on.  I installed
'fgs-mapserver_extended_5.6.3-fgs_9.5-linux-i386.bin' perfectly; but
when I try to use any of the tools, such as mapserv, I get this error:

    /lib/libc.so.6: version `GLIBC_2.4' not found (required by ./mapserv)

I checked and the system has GLIBC 2.3.6 installed.

Is there anything I can do in the FGS environment to solve this problem?

(aside: I believe the answer is no, which means, I cannot install FGS on
this server - in this case, I'm trying to install FGS on another OSGeo
server, as the demo.mapserver.org server blade is still down, from the
recent server problems)

-jeff


--
Jeff McKenna
MapServer Consulting and Training Services
http://www.gatewaygeomatics.com/


_______________________________________________
Foss-gis-suite mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/foss-gis-suite
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: GLIBC version dependency

nsavard
Jeff McKenna wrote:
> when I try to use any of the tools, such as mapserv, I get this error:
>
>     /lib/libc.so.6: version `GLIBC_2.4' not found (required by ./mapserv)
>
> I checked and the system has GLIBC 2.3.6 installed.
>
> Is there anything I can do in the FGS environment to solve this problem?
>
>  
Jeff,

I could not think of something to do to solve this issue.

Norm

_______________________________________________
Foss-gis-suite mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/foss-gis-suite
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: GLIBC version dependency

Mailing Lists-18
Normand,
I believe the stack was built against Fedora core 10+ or a debian version that has a version of GLIBC more advanced than the persons system.
Redhat and Centos are quite behind debian and Fedora prefering to stay in the vary safe zone of tried and tested libraries and applications.

I think that this issue may cause Redhat and Centos to be placed in a not supported list for FGS builds 9.5 post christmas this year.

We had the same iss ue and had to revert to a version built pre christmas this year.

The other option is to build the stack yourself on the system it is to be delivered to.

regards

paul

Normand Savard wrote:
Jeff McKenna wrote:
  
when I try to use any of the tools, such as mapserv, I get this error:

    /lib/libc.so.6: version `GLIBC_2.4' not found (required by ./mapserv)

I checked and the system has GLIBC 2.3.6 installed.

Is there anything I can do in the FGS environment to solve this problem?

  
    
Jeff,

I could not think of something to do to solve this issue.

Norm

_______________________________________________
Foss-gis-suite mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/foss-gis-suite
  


_______________________________________________
Foss-gis-suite mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/foss-gis-suite
Loading...