GDAL export tools innactive

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

GDAL export tools innactive

Dan DeLorenzo
Hello - Can you offer any advice on why the GDAl export interface might now function in FW tools? Im trying to convert a GEOtiff to USGS raster, or any other format and it simply is not creating a file and providing no feedback. Hope you can help - Dan
_______________________________________________
FWTools mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/fwtools
http://fwtools.maptools.org/
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: GDAL export tools innactive

Matt Wilkie-2
Hi Daniel,

FWTools is effectively in stasis. All current Windows development
efforts are targeted towards OSGeo4W (http://trac.osgeo.org/osgeo4w/).

Linux development is a bit more scattered and I'm not well acquainted
with it, perhaps someone else will speak up. In any case  OSGeo-Live is
a good place to start (http://live.osgeo.org/en/index.html).

cheers,

matt wilkie
--------------------------------------------
Geomatics Analyst
Information Management and Technology
Yukon Department of Environment
10 Burns Road * Whitehorse, Yukon * Y1A 4Y9
867-667-8133 Tel * 867-393-7003 Fax
http://environmentyukon.gov.yk.ca/geomatics/
--------------------------------------------

On 28/01/2013 11:14 AM, Daniel Delorenzo wrote:
> Hello - Can you offer any advice on why the GDAl export interface might now function in FW tools? Im trying to convert a GEOtiff to USGS raster, or any other format and it simply is not creating a file and providing no feedback. Hope you can help - Dan
> _______________________________________________
> FWTools mailing list
> [hidden email]
> http://lists.maptools.org/mailman/listinfo/fwtools
> http://fwtools.maptools.org/
>

_______________________________________________
FWTools mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/fwtools
http://fwtools.maptools.org/
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: GDAL export tools innactive

Dan DeLorenzo
Matt - Thanks so much for getting back to me. Ive been using FWtools to convert rasters for several years with no trouble. I installed FW tools on a new machine and the GDAL export has stopped functioning. Specifically, I was trying to convert a geo tiff to a USGS DEM. 

I installed the complete OSGeo4W, and am having the same problem. My data loads well into the viewer, but export fails. Fortunately, with OSGeo4W, I am able to see some feedback from the command line on screen. This is the message I'm getting:


HERE IS THE CONSOLE COPY FROM LOADING THE SOFTWARE, NOT SURE IF ANY OF THE SKIPPED TOOLS MIGHT BE THE CULPRIT:

-----------------------

OSGEO4W home is C:\OSGeo4W
Loading tools from C:\OSGeo4W\apps\openev\tools\calculator.py
... failed to load ... skipping.
Loading tools from C:\OSGeo4W\apps\openev\tools\compose.py
Loading tools from C:\OSGeo4W\apps\openev\tools\fft.py
... failed to load ... skipping.
Loading tools from C:\OSGeo4W\apps\openev\tools\gvrastertools.py
... failed to load ... skipping.
Loading tools from C:\OSGeo4W\apps\openev\tools\isodata.py
Loading tools from C:\OSGeo4W\apps\openev\tools\open_raw.py
Loading tools from C:\OSGeo4W\apps\openev\tools\open_subarea.py
Loading tools from C:\OSGeo4W\apps\openev\tools\reproject.py
Loading tools from C:\OSGeo4W\apps\openev\tools\Tool_autopan.py
Loading tools from C:\OSGeo4W\apps\openev\tools\Tool_BrightContrastGamma.py
Loading tools from C:\OSGeo4W\apps\openev\tools\Tool_DriverList.py
Loading tools from C:\OSGeo4W\apps\openev\tools\Tool_Export.py
Loading tools from C:\OSGeo4W\apps\openev\tools\Tool_ShapesGrid.py
Loading tools from C:\OSGeo4W\apps\openev\tools\wmstool.py


AND HERE IS THE COPY THAT APPEARS AFTER ATTEMPTED EXPORT:


Traceback (most recent call last):
  File "C:\OSGeo4W\apps\openev\pymod\gtk.py", line 125, in __call__
    ret = apply(self.func, a)
  File "C:\OSGeo4W\apps\openev\tools\Tool_Export.py", line 625, in export_cb
    vrt_tree=vrtutils.serializeDataset(rast,vrt_opts,band_list)
  File "C:\OSGeo4W\apps\openev\pymod\vrtutils.py", line 713, in serializeDataset

    gbase=serializeGeoTransform(indataset,vrt_options)
  File "C:\OSGeo4W\apps\openev\pymod\vrtutils.py", line 467, in serializeGeoTran
sform
    gt1=float(gt[1])*Numeric.floor(xsize)/Numeric.floor(dxsize)
AttributeError: 'module' object has no attribute 'floor'


------------------------

This is occurring with all data sets and file formats, so I don't think my specific data is the issue. Would you be in a position to shed any light on my issue? I would greatly appreciate it. Im noticing that my "calculator.py" failed to load and the error occurs after and attempted calculation. Am I missing a piece of Python? - Dan DeLorenzo


Dan De Lorenzo
917.903.7168


On Mon, Jan 28, 2013 at 2:59 PM, Matt Wilkie <[hidden email]> wrote:
Hi Daniel,

FWTools is effectively in stasis. All current Windows development efforts are targeted towards OSGeo4W (http://trac.osgeo.org/osgeo4w/).

Linux development is a bit more scattered and I'm not well acquainted with it, perhaps someone else will speak up. In any case  OSGeo-Live is a good place to start (http://live.osgeo.org/en/index.html).

cheers,

matt wilkie
--------------------------------------------
Geomatics Analyst
Information Management and Technology
Yukon Department of Environment
10 Burns Road * Whitehorse, Yukon * Y1A 4Y9
<a href="tel:867-667-8133" value="+18676678133" target="_blank">867-667-8133 Tel * <a href="tel:867-393-7003" value="+18673937003" target="_blank">867-393-7003 Fax
http://environmentyukon.gov.yk.ca/geomatics/
--------------------------------------------


On 28/01/2013 11:14 AM, Daniel Delorenzo wrote:
Hello - Can you offer any advice on why the GDAl export interface might now function in FW tools? Im trying to convert a GEOtiff to USGS raster, or any other format and it simply is not creating a file and providing no feedback. Hope you can help - Dan
_______________________________________________
FWTools mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/fwtools
http://fwtools.maptools.org/




_______________________________________________
FWTools mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/fwtools
http://fwtools.maptools.org/
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: GDAL export tools innactive

Frank Warmerdam-2
Dan,

Interesting.  It may be related to the version of numpy/Numeric that
gets used, but I'd have thought that this was pretty nailed down with
FWTools or OSGeo4W.

You might try changing Numeric.floor() to math.floor() (and make sure
that math is imported) in the affected scripts.

I wouldn't mind fixing this is OSGeo4W.  I'll try to look at it tonight.

Best regards,
Frank


On Mon, Jan 28, 2013 at 4:27 PM, Dan DeLorenzo <[hidden email]> wrote:

> Matt - Thanks so much for getting back to me. Ive been using FWtools to
> convert rasters for several years with no trouble. I installed FW tools on a
> new machine and the GDAL export has stopped functioning. Specifically, I was
> trying to convert a geo tiff to a USGS DEM.
>
> I installed the complete OSGeo4W, and am having the same problem. My data
> loads well into the viewer, but export fails. Fortunately, with OSGeo4W, I
> am able to see some feedback from the command line on screen. This is the
> message I'm getting:
>
>
> HERE IS THE CONSOLE COPY FROM LOADING THE SOFTWARE, NOT SURE IF ANY OF THE
> SKIPPED TOOLS MIGHT BE THE CULPRIT:
>
> -----------------------
>
> OSGEO4W home is C:\OSGeo4W
> Loading tools from C:\OSGeo4W\apps\openev\tools\calculator.py
> ... failed to load ... skipping.
> Loading tools from C:\OSGeo4W\apps\openev\tools\compose.py
> Loading tools from C:\OSGeo4W\apps\openev\tools\fft.py
> ... failed to load ... skipping.
> Loading tools from C:\OSGeo4W\apps\openev\tools\gvrastertools.py
> ... failed to load ... skipping.
> Loading tools from C:\OSGeo4W\apps\openev\tools\isodata.py
> Loading tools from C:\OSGeo4W\apps\openev\tools\open_raw.py
> Loading tools from C:\OSGeo4W\apps\openev\tools\open_subarea.py
> Loading tools from C:\OSGeo4W\apps\openev\tools\reproject.py
> Loading tools from C:\OSGeo4W\apps\openev\tools\Tool_autopan.py
> Loading tools from C:\OSGeo4W\apps\openev\tools\Tool_BrightContrastGamma.py
> Loading tools from C:\OSGeo4W\apps\openev\tools\Tool_DriverList.py
> Loading tools from C:\OSGeo4W\apps\openev\tools\Tool_Export.py
> Loading tools from C:\OSGeo4W\apps\openev\tools\Tool_ShapesGrid.py
> Loading tools from C:\OSGeo4W\apps\openev\tools\wmstool.py
>
>
> AND HERE IS THE COPY THAT APPEARS AFTER ATTEMPTED EXPORT:
>
>
> Traceback (most recent call last):
>   File "C:\OSGeo4W\apps\openev\pymod\gtk.py", line 125, in __call__
>     ret = apply(self.func, a)
>   File "C:\OSGeo4W\apps\openev\tools\Tool_Export.py", line 625, in export_cb
>     vrt_tree=vrtutils.serializeDataset(rast,vrt_opts,band_list)
>   File "C:\OSGeo4W\apps\openev\pymod\vrtutils.py", line 713, in
> serializeDataset
>
>     gbase=serializeGeoTransform(indataset,vrt_options)
>   File "C:\OSGeo4W\apps\openev\pymod\vrtutils.py", line 467, in
> serializeGeoTran
> sform
>     gt1=float(gt[1])*Numeric.floor(xsize)/Numeric.floor(dxsize)
> AttributeError: 'module' object has no attribute 'floor'
>
>
> ------------------------
>
> This is occurring with all data sets and file formats, so I don't think my
> specific data is the issue. Would you be in a position to shed any light on
> my issue? I would greatly appreciate it. Im noticing that my "calculator.py"
> failed to load and the error occurs after and attempted calculation. Am I
> missing a piece of Python? - Dan DeLorenzo
>
>
> Dan De Lorenzo
> 917.903.7168
>
>
> On Mon, Jan 28, 2013 at 2:59 PM, Matt Wilkie <[hidden email]> wrote:
>>
>> Hi Daniel,
>>
>> FWTools is effectively in stasis. All current Windows development efforts
>> are targeted towards OSGeo4W (http://trac.osgeo.org/osgeo4w/).
>>
>> Linux development is a bit more scattered and I'm not well acquainted with
>> it, perhaps someone else will speak up. In any case  OSGeo-Live is a good
>> place to start (http://live.osgeo.org/en/index.html).
>>
>> cheers,
>>
>> matt wilkie
>> --------------------------------------------
>> Geomatics Analyst
>> Information Management and Technology
>> Yukon Department of Environment
>> 10 Burns Road * Whitehorse, Yukon * Y1A 4Y9
>> 867-667-8133 Tel * 867-393-7003 Fax
>> http://environmentyukon.gov.yk.ca/geomatics/
>> --------------------------------------------
>>
>>
>> On 28/01/2013 11:14 AM, Daniel Delorenzo wrote:
>>>
>>> Hello - Can you offer any advice on why the GDAl export interface might
>>> now function in FW tools? Im trying to convert a GEOtiff to USGS raster, or
>>> any other format and it simply is not creating a file and providing no
>>> feedback. Hope you can help - Dan
>>> _______________________________________________
>>> FWTools mailing list
>>> [hidden email]
>>> http://lists.maptools.org/mailman/listinfo/fwtools
>>> http://fwtools.maptools.org/
>>>
>>
>
>
> _______________________________________________
> FWTools mailing list
> [hidden email]
> http://lists.maptools.org/mailman/listinfo/fwtools
> http://fwtools.maptools.org/
>



--
---------------------------------------+--------------------------------------
I set the clouds in motion - turn up   | Frank Warmerdam, [hidden email]
light and sound - activate the windows | http://pobox.com/~warmerdam
and watch the world go round - Rush    | Geospatial Software Developer
_______________________________________________
FWTools mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/fwtools
http://fwtools.maptools.org/
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: GDAL export tools innactive

Dan DeLorenzo
You guys are the most responsive open source software group Ive ever dealt with. THANKS!  Frank - I'll try reinstalling numpy and numeric first, and then try modifying the scripts. Look forward to hearing what you find. Thanks again - Dan 

Dan De Lorenzo
917.903.7168


On Mon, Jan 28, 2013 at 7:39 PM, Frank Warmerdam <[hidden email]> wrote:
Dan,

Interesting.  It may be related to the version of numpy/Numeric that
gets used, but I'd have thought that this was pretty nailed down with
FWTools or OSGeo4W.

You might try changing Numeric.floor() to math.floor() (and make sure
that math is imported) in the affected scripts.

I wouldn't mind fixing this is OSGeo4W.  I'll try to look at it tonight.

Best regards,
Frank


On Mon, Jan 28, 2013 at 4:27 PM, Dan DeLorenzo <[hidden email]> wrote:
> Matt - Thanks so much for getting back to me. Ive been using FWtools to
> convert rasters for several years with no trouble. I installed FW tools on a
> new machine and the GDAL export has stopped functioning. Specifically, I was
> trying to convert a geo tiff to a USGS DEM.
>
> I installed the complete OSGeo4W, and am having the same problem. My data
> loads well into the viewer, but export fails. Fortunately, with OSGeo4W, I
> am able to see some feedback from the command line on screen. This is the
> message I'm getting:
>
>
> HERE IS THE CONSOLE COPY FROM LOADING THE SOFTWARE, NOT SURE IF ANY OF THE
> SKIPPED TOOLS MIGHT BE THE CULPRIT:
>
> -----------------------
>
> OSGEO4W home is C:\OSGeo4W
> Loading tools from C:\OSGeo4W\apps\openev\tools\calculator.py
> ... failed to load ... skipping.
> Loading tools from C:\OSGeo4W\apps\openev\tools\compose.py
> Loading tools from C:\OSGeo4W\apps\openev\tools\fft.py
> ... failed to load ... skipping.
> Loading tools from C:\OSGeo4W\apps\openev\tools\gvrastertools.py
> ... failed to load ... skipping.
> Loading tools from C:\OSGeo4W\apps\openev\tools\isodata.py
> Loading tools from C:\OSGeo4W\apps\openev\tools\open_raw.py
> Loading tools from C:\OSGeo4W\apps\openev\tools\open_subarea.py
> Loading tools from C:\OSGeo4W\apps\openev\tools\reproject.py
> Loading tools from C:\OSGeo4W\apps\openev\tools\Tool_autopan.py
> Loading tools from C:\OSGeo4W\apps\openev\tools\Tool_BrightContrastGamma.py
> Loading tools from C:\OSGeo4W\apps\openev\tools\Tool_DriverList.py
> Loading tools from C:\OSGeo4W\apps\openev\tools\Tool_Export.py
> Loading tools from C:\OSGeo4W\apps\openev\tools\Tool_ShapesGrid.py
> Loading tools from C:\OSGeo4W\apps\openev\tools\wmstool.py
>
>
> AND HERE IS THE COPY THAT APPEARS AFTER ATTEMPTED EXPORT:
>
>
> Traceback (most recent call last):
>   File "C:\OSGeo4W\apps\openev\pymod\gtk.py", line 125, in __call__
>     ret = apply(self.func, a)
>   File "C:\OSGeo4W\apps\openev\tools\Tool_Export.py", line 625, in export_cb
>     vrt_tree=vrtutils.serializeDataset(rast,vrt_opts,band_list)
>   File "C:\OSGeo4W\apps\openev\pymod\vrtutils.py", line 713, in
> serializeDataset
>
>     gbase=serializeGeoTransform(indataset,vrt_options)
>   File "C:\OSGeo4W\apps\openev\pymod\vrtutils.py", line 467, in
> serializeGeoTran
> sform
>     gt1=float(gt[1])*Numeric.floor(xsize)/Numeric.floor(dxsize)
> AttributeError: 'module' object has no attribute 'floor'
>
>
> ------------------------
>
> This is occurring with all data sets and file formats, so I don't think my
> specific data is the issue. Would you be in a position to shed any light on
> my issue? I would greatly appreciate it. Im noticing that my "calculator.py"
> failed to load and the error occurs after and attempted calculation. Am I
> missing a piece of Python? - Dan DeLorenzo
>
>
> Dan De Lorenzo
> 917.903.7168
>
>
> On Mon, Jan 28, 2013 at 2:59 PM, Matt Wilkie <[hidden email]> wrote:
>>
>> Hi Daniel,
>>
>> FWTools is effectively in stasis. All current Windows development efforts
>> are targeted towards OSGeo4W (http://trac.osgeo.org/osgeo4w/).
>>
>> Linux development is a bit more scattered and I'm not well acquainted with
>> it, perhaps someone else will speak up. In any case  OSGeo-Live is a good
>> place to start (http://live.osgeo.org/en/index.html).
>>
>> cheers,
>>
>> matt wilkie
>> --------------------------------------------
>> Geomatics Analyst
>> Information Management and Technology
>> Yukon Department of Environment
>> 10 Burns Road * Whitehorse, Yukon * Y1A 4Y9
>> <a href="tel:867-667-8133" value="+18676678133">867-667-8133 Tel * <a href="tel:867-393-7003" value="+18673937003">867-393-7003 Fax
>> http://environmentyukon.gov.yk.ca/geomatics/
>> --------------------------------------------
>>
>>
>> On 28/01/2013 11:14 AM, Daniel Delorenzo wrote:
>>>
>>> Hello - Can you offer any advice on why the GDAl export interface might
>>> now function in FW tools? Im trying to convert a GEOtiff to USGS raster, or
>>> any other format and it simply is not creating a file and providing no
>>> feedback. Hope you can help - Dan
>>> _______________________________________________
>>> FWTools mailing list
>>> [hidden email]
>>> http://lists.maptools.org/mailman/listinfo/fwtools
>>> http://fwtools.maptools.org/
>>>
>>
>
>
> _______________________________________________
> FWTools mailing list
> [hidden email]
> http://lists.maptools.org/mailman/listinfo/fwtools
> http://fwtools.maptools.org/
>



--
---------------------------------------+--------------------------------------
I set the clouds in motion - turn up   | Frank Warmerdam, [hidden email]
light and sound - activate the windows | http://pobox.com/~warmerdam
and watch the world go round - Rush    | Geospatial Software Developer


_______________________________________________
FWTools mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/fwtools
http://fwtools.maptools.org/
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: GDAL export tools innactive

Dan DeLorenzo
In reply to this post by Frank Warmerdam-2
UPDATE: So it seems that Frank is on to something... I replaced all references to Numeric.floor with math.floor in this file "C:\OSGeo4W\apps\openev\pymod\vrtutils.py"  and now Im exporting just fine. Thanks for your help and let me know if there are likely adverse affects to this, or if there is something I should changes elsewhere to get it running properly. - D



Dan De Lorenzo
917.903.7168


On Mon, Jan 28, 2013 at 7:39 PM, Frank Warmerdam <[hidden email]> wrote:
Dan,

Interesting.  It may be related to the version of numpy/Numeric that
gets used, but I'd have thought that this was pretty nailed down with
FWTools or OSGeo4W.

You might try changing Numeric.floor() to math.floor() (and make sure
that math is imported) in the affected scripts.

I wouldn't mind fixing this is OSGeo4W.  I'll try to look at it tonight.

Best regards,
Frank


On Mon, Jan 28, 2013 at 4:27 PM, Dan DeLorenzo <[hidden email]> wrote:
> Matt - Thanks so much for getting back to me. Ive been using FWtools to
> convert rasters for several years with no trouble. I installed FW tools on a
> new machine and the GDAL export has stopped functioning. Specifically, I was
> trying to convert a geo tiff to a USGS DEM.
>
> I installed the complete OSGeo4W, and am having the same problem. My data
> loads well into the viewer, but export fails. Fortunately, with OSGeo4W, I
> am able to see some feedback from the command line on screen. This is the
> message I'm getting:
>
>
> HERE IS THE CONSOLE COPY FROM LOADING THE SOFTWARE, NOT SURE IF ANY OF THE
> SKIPPED TOOLS MIGHT BE THE CULPRIT:
>
> -----------------------
>
> OSGEO4W home is C:\OSGeo4W
> Loading tools from C:\OSGeo4W\apps\openev\tools\calculator.py
> ... failed to load ... skipping.
> Loading tools from C:\OSGeo4W\apps\openev\tools\compose.py
> Loading tools from C:\OSGeo4W\apps\openev\tools\fft.py
> ... failed to load ... skipping.
> Loading tools from C:\OSGeo4W\apps\openev\tools\gvrastertools.py
> ... failed to load ... skipping.
> Loading tools from C:\OSGeo4W\apps\openev\tools\isodata.py
> Loading tools from C:\OSGeo4W\apps\openev\tools\open_raw.py
> Loading tools from C:\OSGeo4W\apps\openev\tools\open_subarea.py
> Loading tools from C:\OSGeo4W\apps\openev\tools\reproject.py
> Loading tools from C:\OSGeo4W\apps\openev\tools\Tool_autopan.py
> Loading tools from C:\OSGeo4W\apps\openev\tools\Tool_BrightContrastGamma.py
> Loading tools from C:\OSGeo4W\apps\openev\tools\Tool_DriverList.py
> Loading tools from C:\OSGeo4W\apps\openev\tools\Tool_Export.py
> Loading tools from C:\OSGeo4W\apps\openev\tools\Tool_ShapesGrid.py
> Loading tools from C:\OSGeo4W\apps\openev\tools\wmstool.py
>
>
> AND HERE IS THE COPY THAT APPEARS AFTER ATTEMPTED EXPORT:
>
>
> Traceback (most recent call last):
>   File "C:\OSGeo4W\apps\openev\pymod\gtk.py", line 125, in __call__
>     ret = apply(self.func, a)
>   File "C:\OSGeo4W\apps\openev\tools\Tool_Export.py", line 625, in export_cb
>     vrt_tree=vrtutils.serializeDataset(rast,vrt_opts,band_list)
>   File "C:\OSGeo4W\apps\openev\pymod\vrtutils.py", line 713, in
> serializeDataset
>
>     gbase=serializeGeoTransform(indataset,vrt_options)
>   File "C:\OSGeo4W\apps\openev\pymod\vrtutils.py", line 467, in
> serializeGeoTran
> sform
>     gt1=float(gt[1])*Numeric.floor(xsize)/Numeric.floor(dxsize)
> AttributeError: 'module' object has no attribute 'floor'
>
>
> ------------------------
>
> This is occurring with all data sets and file formats, so I don't think my
> specific data is the issue. Would you be in a position to shed any light on
> my issue? I would greatly appreciate it. Im noticing that my "calculator.py"
> failed to load and the error occurs after and attempted calculation. Am I
> missing a piece of Python? - Dan DeLorenzo
>
>
> Dan De Lorenzo
> 917.903.7168
>
>
> On Mon, Jan 28, 2013 at 2:59 PM, Matt Wilkie <[hidden email]> wrote:
>>
>> Hi Daniel,
>>
>> FWTools is effectively in stasis. All current Windows development efforts
>> are targeted towards OSGeo4W (http://trac.osgeo.org/osgeo4w/).
>>
>> Linux development is a bit more scattered and I'm not well acquainted with
>> it, perhaps someone else will speak up. In any case  OSGeo-Live is a good
>> place to start (http://live.osgeo.org/en/index.html).
>>
>> cheers,
>>
>> matt wilkie
>> --------------------------------------------
>> Geomatics Analyst
>> Information Management and Technology
>> Yukon Department of Environment
>> 10 Burns Road * Whitehorse, Yukon * Y1A 4Y9
>> <a href="tel:867-667-8133" value="+18676678133">867-667-8133 Tel * <a href="tel:867-393-7003" value="+18673937003">867-393-7003 Fax
>> http://environmentyukon.gov.yk.ca/geomatics/
>> --------------------------------------------
>>
>>
>> On 28/01/2013 11:14 AM, Daniel Delorenzo wrote:
>>>
>>> Hello - Can you offer any advice on why the GDAl export interface might
>>> now function in FW tools? Im trying to convert a GEOtiff to USGS raster, or
>>> any other format and it simply is not creating a file and providing no
>>> feedback. Hope you can help - Dan
>>> _______________________________________________
>>> FWTools mailing list
>>> [hidden email]
>>> http://lists.maptools.org/mailman/listinfo/fwtools
>>> http://fwtools.maptools.org/
>>>
>>
>
>
> _______________________________________________
> FWTools mailing list
> [hidden email]
> http://lists.maptools.org/mailman/listinfo/fwtools
> http://fwtools.maptools.org/
>



--
---------------------------------------+--------------------------------------
I set the clouds in motion - turn up   | Frank Warmerdam, [hidden email]
light and sound - activate the windows | http://pobox.com/~warmerdam
and watch the world go round - Rush    | Geospatial Software Developer


_______________________________________________
FWTools mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/fwtools
http://fwtools.maptools.org/
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: GDAL export tools innactive

Matt Wilkie-2
Thanks for the kind words Dan. I often don't feel I'm being that
"responsive". ;-)

Also thanks for reporting back with what seems to be working for you.

cheers,

matt wilkie
--------------------------------------------
Geomatics Analyst
Information Management and Technology
Yukon Department of Environment
10 Burns Road * Whitehorse, Yukon * Y1A 4Y9
867-667-8133 Tel * 867-393-7003 Fax
http://environmentyukon.gov.yk.ca/geomatics/
--------------------------------------------



_______________________________________________
FWTools mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/fwtools
http://fwtools.maptools.org/
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: GDAL export tools innactive

Dan DeLorenzo
In reply to this post by Dan DeLorenzo
Frank - Did you ever sort this? I ve confirmed that this issue is not unique to my system, meaning the GDAL export tools are not functional for anyone that downloads OSGEO4W. - D

Dan De Lorenzo
917.903.7168


On Mon, Jan 28, 2013 at 8:05 PM, Dan DeLorenzo <[hidden email]> wrote:
You guys are the most responsive open source software group Ive ever dealt with. THANKS!  Frank - I'll try reinstalling numpy and numeric first, and then try modifying the scripts. Look forward to hearing what you find. Thanks again - Dan 

Dan De Lorenzo
<a href="tel:917.903.7168" value="+19179037168" target="_blank">917.903.7168


On Mon, Jan 28, 2013 at 7:39 PM, Frank Warmerdam <[hidden email]> wrote:
Dan,

Interesting.  It may be related to the version of numpy/Numeric that
gets used, but I'd have thought that this was pretty nailed down with
FWTools or OSGeo4W.

You might try changing Numeric.floor() to math.floor() (and make sure
that math is imported) in the affected scripts.

I wouldn't mind fixing this is OSGeo4W.  I'll try to look at it tonight.

Best regards,
Frank


On Mon, Jan 28, 2013 at 4:27 PM, Dan DeLorenzo <[hidden email]> wrote:
> Matt - Thanks so much for getting back to me. Ive been using FWtools to
> convert rasters for several years with no trouble. I installed FW tools on a
> new machine and the GDAL export has stopped functioning. Specifically, I was
> trying to convert a geo tiff to a USGS DEM.
>
> I installed the complete OSGeo4W, and am having the same problem. My data
> loads well into the viewer, but export fails. Fortunately, with OSGeo4W, I
> am able to see some feedback from the command line on screen. This is the
> message I'm getting:
>
>
> HERE IS THE CONSOLE COPY FROM LOADING THE SOFTWARE, NOT SURE IF ANY OF THE
> SKIPPED TOOLS MIGHT BE THE CULPRIT:
>
> -----------------------
>
> OSGEO4W home is C:\OSGeo4W
> Loading tools from C:\OSGeo4W\apps\openev\tools\calculator.py
> ... failed to load ... skipping.
> Loading tools from C:\OSGeo4W\apps\openev\tools\compose.py
> Loading tools from C:\OSGeo4W\apps\openev\tools\fft.py
> ... failed to load ... skipping.
> Loading tools from C:\OSGeo4W\apps\openev\tools\gvrastertools.py
> ... failed to load ... skipping.
> Loading tools from C:\OSGeo4W\apps\openev\tools\isodata.py
> Loading tools from C:\OSGeo4W\apps\openev\tools\open_raw.py
> Loading tools from C:\OSGeo4W\apps\openev\tools\open_subarea.py
> Loading tools from C:\OSGeo4W\apps\openev\tools\reproject.py
> Loading tools from C:\OSGeo4W\apps\openev\tools\Tool_autopan.py
> Loading tools from C:\OSGeo4W\apps\openev\tools\Tool_BrightContrastGamma.py
> Loading tools from C:\OSGeo4W\apps\openev\tools\Tool_DriverList.py
> Loading tools from C:\OSGeo4W\apps\openev\tools\Tool_Export.py
> Loading tools from C:\OSGeo4W\apps\openev\tools\Tool_ShapesGrid.py
> Loading tools from C:\OSGeo4W\apps\openev\tools\wmstool.py
>
>
> AND HERE IS THE COPY THAT APPEARS AFTER ATTEMPTED EXPORT:
>
>
> Traceback (most recent call last):
>   File "C:\OSGeo4W\apps\openev\pymod\gtk.py", line 125, in __call__
>     ret = apply(self.func, a)
>   File "C:\OSGeo4W\apps\openev\tools\Tool_Export.py", line 625, in export_cb
>     vrt_tree=vrtutils.serializeDataset(rast,vrt_opts,band_list)
>   File "C:\OSGeo4W\apps\openev\pymod\vrtutils.py", line 713, in
> serializeDataset
>
>     gbase=serializeGeoTransform(indataset,vrt_options)
>   File "C:\OSGeo4W\apps\openev\pymod\vrtutils.py", line 467, in
> serializeGeoTran
> sform
>     gt1=float(gt[1])*Numeric.floor(xsize)/Numeric.floor(dxsize)
> AttributeError: 'module' object has no attribute 'floor'
>
>
> ------------------------
>
> This is occurring with all data sets and file formats, so I don't think my
> specific data is the issue. Would you be in a position to shed any light on
> my issue? I would greatly appreciate it. Im noticing that my "calculator.py"
> failed to load and the error occurs after and attempted calculation. Am I
> missing a piece of Python? - Dan DeLorenzo
>
>
> Dan De Lorenzo
> <a href="tel:917.903.7168" value="+19179037168" target="_blank">917.903.7168
>
>
> On Mon, Jan 28, 2013 at 2:59 PM, Matt Wilkie <[hidden email]> wrote:
>>
>> Hi Daniel,
>>
>> FWTools is effectively in stasis. All current Windows development efforts
>> are targeted towards OSGeo4W (http://trac.osgeo.org/osgeo4w/).
>>
>> Linux development is a bit more scattered and I'm not well acquainted with
>> it, perhaps someone else will speak up. In any case  OSGeo-Live is a good
>> place to start (http://live.osgeo.org/en/index.html).
>>
>> cheers,
>>
>> matt wilkie
>> --------------------------------------------
>> Geomatics Analyst
>> Information Management and Technology
>> Yukon Department of Environment
>> 10 Burns Road * Whitehorse, Yukon * Y1A 4Y9
>> <a href="tel:867-667-8133" value="+18676678133" target="_blank">867-667-8133 Tel * <a href="tel:867-393-7003" value="+18673937003" target="_blank">867-393-7003 Fax
>> http://environmentyukon.gov.yk.ca/geomatics/
>> --------------------------------------------
>>
>>
>> On 28/01/2013 11:14 AM, Daniel Delorenzo wrote:
>>>
>>> Hello - Can you offer any advice on why the GDAl export interface might
>>> now function in FW tools? Im trying to convert a GEOtiff to USGS raster, or
>>> any other format and it simply is not creating a file and providing no
>>> feedback. Hope you can help - Dan
>>> _______________________________________________
>>> FWTools mailing list
>>> [hidden email]
>>> http://lists.maptools.org/mailman/listinfo/fwtools
>>> http://fwtools.maptools.org/
>>>
>>
>
>
> _______________________________________________
> FWTools mailing list
> [hidden email]
> http://lists.maptools.org/mailman/listinfo/fwtools
> http://fwtools.maptools.org/
>



--
---------------------------------------+--------------------------------------
I set the clouds in motion - turn up   | Frank Warmerdam, [hidden email]
light and sound - activate the windows | http://pobox.com/~warmerdam
and watch the world go round - Rush    | Geospatial Software Developer



_______________________________________________
FWTools mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/fwtools
http://fwtools.maptools.org/
Loading...