FGS Installation

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

FGS Installation

Dylan Rawlins
Hi,

Please can anyone help me with my FGS installation. I am installing "fgs-mapserver_extended_5.6.3-fgs_9.5-linux-i386.bin"

I get the following errors:

cannot convert $libdir in lwpostgis.sql or postgis.sql: no such file..
! cannot convert $libdir in lwpostgis_upgrade.sql or postgis_upgrade_xxx.sql: no such file..
! cannot convert $libdir in spatial_ref_sys.sql, no such file..

As a result, postgresql is installed but I can't create spatial tables.

Many thanks
_______________________________________________
Foss-gis-suite mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/foss-gis-suite
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: FGS Installation

Julien-Samuel Lacroix-2
Hi,

What command did you use?

Julien

On 10-07-20 10:54 AM, Dylan Rawlins wrote:

> Hi,
>
> Please can anyone help me with my FGS installation. I am installing
> "fgs-mapserver_extended_5.6.3-fgs_9.5-linux-i386.bin"
>
> I get the following errors:
>
> cannot convert $libdir in lwpostgis.sql or postgis.sql: no such file..
> ! cannot convert $libdir in lwpostgis_upgrade.sql or
> postgis_upgrade_xxx.sql: no such file..
> ! cannot convert $libdir in spatial_ref_sys.sql, no such file..
>
> As a result, postgresql is installed but I can't create spatial tables.
>
> Many thanks
>
>
>
> _______________________________________________
> Foss-gis-suite mailing list
> [hidden email]
> http://lists.maptools.org/mailman/listinfo/foss-gis-suite

--
Julien-Samuel Lacroix
Mapgears
http://www.mapgears.com/
_______________________________________________
Foss-gis-suite mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/foss-gis-suite
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

FGS Installation

Dylan Rawlins
In reply to this post by Dylan Rawlins
Hi,

I get this far ...
    Go to your FGS installation root directory and do ". setenv.sh"
    Do "FGS start"
    Execute : createdb yourdb
    Execute : createlang plpgsql yourdb
    Execute : psql -f ..\share\contrib\lwpostgis.sql yourdb

and I get an error saying that it cannot locate the lwpostgis.sql file. I searched my entire hard drive and can't find the file. I also looked for any *.sql file that would relate to postgis and there is nothing. I force installed a lower version of postgis (1.3.5) and the lwpostgis file was there. But then it won't work with postgresql 8.4. So I force installed 8.3 and then nothing worked - couldn't even get a connection to the DB. So I have gone back to the original versions that I downloaded and am stuck wiht the same problem.

Any ideas,
Thanks
Dylan
_______________________________________________
Foss-gis-suite mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/foss-gis-suite
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: FGS Installation

Julien-Samuel Lacroix-2
Hi,

Is PostGIS installed in your FGS?

Go to your FGS installation root directory
$ ls etc/fgs/pkgs/

What is the output of that?

If you don't see postgis-lib in that, install it doing:
$ . setenv.sh
$ fgs install postgis-lib

Does that work?

Note that installing another postgresql on your server may cause problem
because it will probably end up running on the same port as FGS's
PostgreSQL. You can change FGS port in
etc/fgs/pkgs/postgresql-server/pgsql.conf

Julien


On 10-07-20 11:22 AM, Dylan Rawlins wrote:

> Hi,
>
> I get this far ...
> Go to your FGS installation root directory and do ". setenv.sh"
> Do "FGS start"
> Execute : createdb yourdb
> Execute : createlang plpgsql yourdb
> Execute : psql -f ..\share\contrib\lwpostgis.sql yourdb
>
> and I get an error saying that it cannot locate the lwpostgis.sql file.
> I searched my entire hard drive and can't find the file. I also looked
> for any *.sql file that would relate to postgis and there is nothing. I
> force installed a lower version of postgis (1.3.5) and the lwpostgis
> file was there. But then it won't work with postgresql 8.4. So I force
> installed 8.3 and then nothing worked - couldn't even get a connection
> to the DB. So I have gone back to the original versions that I
> downloaded and am stuck wiht the same problem.
>
> Any ideas,
> Thanks
> Dylan
>
>
>
> _______________________________________________
> Foss-gis-suite mailing list
> [hidden email]
> http://lists.maptools.org/mailman/listinfo/foss-gis-suite

--
Julien-Samuel Lacroix
Mapgears
http://www.mapgears.com/
_______________________________________________
Foss-gis-suite mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/foss-gis-suite
Loading...