Quantcast

[Bug 1965] New: Update log4php to the php5 port

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[Bug 1965] New: Update log4php to the php5 port

bugzilla-daemon (Bugzilla)-13
http://bugzilla.maptools.org/show_bug.cgi?id=1965

           Summary: Update log4php to the php5 port
           Product: CartoWeb
           Version: unspecified
          Platform: PC
        OS/Version: Linux
            Status: NEW
          Severity: enhancement
          Priority: P4
         Component: Core
        AssignedTo: [hidden email]
        ReportedBy: [hidden email]


log4php 0.90 which is actually used in cw3.5 are somewhat incompatible with php5

Generate lots of warning and strict standard error which render unsable the use
of a php strict dev env.
You couldn't find usefull warning in the mess.

There's also some contradiction in the cw3 code as it use static function call
which are only present in the svn snapshot of log4php

http://svn.apache.org/viewcvs.cgi/incubator/log4php

like for example
PHP Strict standards:  Non-static method LoggerLog::internalDebugging() should
not be called statically, assuming $this from
incompatible context in
/home/bruno/workspace/cw3dev/include/log4php/LoggerLog.php on line 49



------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.


Please do NOT reply to this email, use the link above instead to
login to bugzilla and submit your comment. Any email reply to this
address will be lost.
_______________________________________________
Cartoweb-dev mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/cartoweb-dev
Loading...