[Bug 1825] [Chameleon-Widget]When there is more than one legendtemplate widgets only one of them is updated in JSAPI mode

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[Bug 1825] [Chameleon-Widget]When there is more than one legendtemplate widgets only one of them is updated in JSAPI mode

bugzilla-daemon (Bugzilla)-13
http://bugzilla.maptools.org/show_bug.cgi?id=1825

[hidden email] changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|ASSIGNED                    |RESOLVED
         Resolution|                            |FIXED



------- Additional Comments From [hidden email]  2007-11-20 13:07 -------
Fixed in CVS.  I added an HTML variable in UpdateMap.php to pass on the widget
id.  I made unique the LegendTemplateWRegisterForEvent() and
LegendTemplateWLayersChanged() functions by adding the widget id.  Finally I
modified CWCLegendTemplateProcessed() to concatenate legendTemplateDiv with the
id passed in the form.


....
szLegendTemplateDivId = doc.forms[0].LEGEND_TEMPLATE_DIV_ID.value;
...

this.GetDocumentDivObject("legendTemplateDiv"+szLegendTemplateDivId).innerHTML =
"<table>" + newString + "</table>";
...



------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.


Please do NOT reply to this email, use the link above instead to
login to bugzilla and submit your comment. Any email reply to this
address will be lost.
_______________________________________________
Chameleon-dev mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/chameleon-dev
Loading...